Course Page Not Found In Maple Release

Hi guys,

I am setting up open edX by using release Maple. The code of tutor is using latest version v13.0.1
I can create a course in Studio. However, there was an issue if I click on View live button or access the course in LMS. The URL looks like this:
{{LMS_BASE}}/courses/course-v1:orgX+NC_01+2022_NC_01/jump_to/None/course/course-v1:orgX+NC_01+2022_NC_01

We can see there is a None in the path.

Does anyone have the same experience to fix it?
I also researched both forums/issues in Github of edx-platform (overhang and opened) but could not find any solution.

I report here and hope someone can help. In the meanwhile, I am investigating it and reply here if figure out any clue.

Many thanks,
Thin Nguyen

This was my mistake.

The solution is (followed by document https://openedx.atlassian.net/wiki/spaces/COMM/pages/2603816700/Maple)

2 Likes

You should not enable the legacy experience, as it was untested for the release, and I believe it is not supported anymore. That’s why the tutor-mfe plugin is now enabled by default in all installations. You should install and enable it, if it’s not already done.

1 Like

Thanks for letting me know @regis. I will remove the two waffle flags, and install tutor mfe. I will update this post soon

Hi, I experience a problem with redirect that should open the courses pages in LMS
http://app[URL]/learning/course/[COURSE ID]/home
Have activated MFE plugin. No problem in Studio.

Any suggestions? Thanks!

Hi @helgeh ,

The plugin tutor-mfe worked well on my local machine.

  1. I have disabled the two flags courseware.use_legacy_frontend and course_home.course_home_use_legacy_frontend.
  2. Restarting lms and cms
  3. Run command tutor local init

Hi Regis,

Is there a flag that I should perhaps disable to make {LMS_HOME}/courses/{COURSE ID}/course forward to the frontend MFE? When I link to my course via Richie, it goes to the legacy frontend and intermittently throws a 500 error code. However, if I update the Richie resource to the app frontend, it doesn’t sync enrollments properly.

@edunomic May I suggest that you open a separate thread for your question since it’s related to Richie :slight_smile: .

Sure, I can do that for a Richie specific fix. But still the overall question stands for this thread: is there a waffle flag to redirect legacy course pages to the MFE, similar to the redirect flags for other MFEs? i.e. if people have legacy pages bookmarked or old links still point to it.

Quick note on the question I raised, it looks like the legacy pages were not forwarding to learning frontend MFE pages while logged in as a superuser. However for other users they forward just fine.

Note for others who encounter the same problem: I never enabled any legacy experience. I only did the tutor upgrade from Lilac to Maple with

docker system prune -a
tutor local stop
sudo rsync -avr "$(tutor config printroot)"/ /tmp/tutor-backup/
sudo curl -L "https://github.com/overhangio/tutor/releases/download/v13.0.3/tutor-$(uname -s)_$(uname -m)" -o /usr/local/bin/tutor
sudo chmod 0755 /usr/local/bin/tutor
tutor local upgrade --from=lilac
tutor config save
tutor images build openedx
tutor local quickstart

And when it was done, I had this error. Because apparently the MFE plugin was not enabled by default. So I had to do

tutor plugins enable mfe
tutor config save
tutor local quickstart

to resolve the issue and fix the “view live” not working.

p.s. another undocumented issue is that if you were already using forums you need to re-enable them too

tutor plugins enable forum
tutor config save
tutor local quickstart
2 Likes

Maple’s release notes mention being able to revert to the legacy courseware experience

The courseware.use_legacy_frontend and course_home.course_home_use_legacy_frontend Waffle flags can be toggled on (either globally or per-course-run) in order to revert to the legacy (LMS Django-rendered) courseware experience.

Is this not supported with Tutor?

It was my understanding, based on conversations in the build/test/release working group, that the legacy experience was unsupported.

:thinking: I’m wondering if we should be enabling the legacy experience by default when the MFE is not enabled… I guess we could. For instance, we could add the following to the lms/init script:

{%- if MFE_LEARNING_MFE_APP is not defined or not MFE_LEARNING_MFE_APP%}
(./manage.py lms waffle_flag --list | grep courseware.use_legacy_frontend) || ./manage.py lms waffle_flag --create --everyone courseware.use_legacy_frontend
...
{% endif %}

But it’s going to be difficult to make sure that these flags are correctly set for all users, all the time. In particular, when we enable and then disable the mfe plugin, I’m not sure in what state these flags should be… So let’s just ignore this for now, and we’ll just assume that users will enable the flags themselves if need be.

@helgeh, did you find the solution, I got the same problem in a recent installation.


and course URL looks like
https://apps.mydomain.com/learning/course/course-v1:DagLearning+CS101+2021/home

Did I miss anything important in configuration settings?. For any quick fix, thank you in advance.

Hi, Harrp!

The error is still there after upgrade to Maple 1.11. But it might be a problem with the Chrome browser that I use. When I use Firefox or the beta version of Chrome, it seems to work OK.

Good luck!

Helge

I had a similar error when importing courses, which I realized that all these were hidden, so I changed the visibility in the catalog to about