Local quickstart failed with status 137

After enabling new plugin for timed exams -


Quickstart fails with status 137

I found that it’s a frequent problem, but the suggested solution also didn’t work.

tutor local stop
sudo rm -rf "$(tutor config printroot)/data/mysql"
tutor local quickstart

When I disabled the plugin, same problem persisted.

Then I deleted the newly made plugins directory and then run local quickstart successfully.

Any idea why this error pops us / what to do to enable timed exams ?


there might be json file error. check your lms.env.json ad cms.env.json files

share the log of exactly what error you got. It can help in solving your issue.


1 Like

May I know where and what exactly should I look for json files ?

the error is very common and had listed by @CherieCAF here , which is why I didn’t paste the log.

I deleted mysql as mentioned but it didn’t help

Now with absolutely no reason

Error: Command failed with status 137: docker-compose -f /home/tutor/.local/share/tutor/env/local/docker-compose.yml --project-name tutor_local exec lms sh -e -c dockerize -wait tcp://mysql:3306 -timeout 20s

echo "Loading settings $DJANGO_SETTINGS_MODULE"

./manage.py lms migrate

./manage.py lms create_oauth2_client \
    "http://androidapp.com" "http://androidapp.com/redirect" public \
    --client_id android --client_secret MSBf5gEEgWYSDLCvaevPSVtP \
# Fix incorrect uploaded file path
if [ -d /openedx/data/uploads/ ]; then
  if [ -n "$(ls -A /openedx/data/uploads/)" ]; then
    echo "Migrating LMS uploaded files to shared directory"
    mv /openedx/data/uploads/* /openedx/media/
    rm -rf /openedx/data/uploads/

Did you recreate your MYSQL db after you deleted it? You can run tutor local init or tutor local quickstart to recreate it. I would also run tutor local logs --tail=100 -f and see if there are any errors being logged on running containers.