Local Deployment Error "Couldn't connect to docker daemon"

Hi I went through Tutor doc to install Open Edx for local development, unfortunately I got every time the same error.

Noting that I installed Docker CE and Docker-Compose and verified that they are working

Any help please

This didn’t happen to me. You can try to restart your docker or reboot your computer, or docker logout.

Thanks Jay, Am using Ubuntu VM on VirtualBox and did restart the VM several times also reinstalled Docker CE and Docker-Compose but got the same error.

@SayHi you can try use sudo command. Maybe is you account is not in docker group so it didn’t have exec right .

Thanks Carlos. Yes it was a right problem. Now it’s working.

you should check this https://github.com/overhangio/tutor/issues/235. if you use the sudo the env should be careful

Hi @SayHi! You should really avoid running docker in sudo mode. Please read https://docs.docker.com/install/linux/linux-postinstall/.

1 Like

run the quickstart with the sudo command
$ sudo tutor local quickstart

@kush11 NO NO NO. Didn’t you read the answers above?