Install cairn on maple

When going to install Cairn on Maple I am not seeing it show up in the plugins list. I ran tutor license install tutor-cairn and it ran successfully. If I run it again it says requirements satisfied. However, I do not see Cairn in my plugins list. Infact, I am not seeing any of the wizard plugins show up after installation. I have seen a similar issue but I am not sure if its relevant.

My tutor --version tutor, version 13.1.0
Tutor license version license==13.0.0
plugins list

android==13.0.0 (disabled)
discovery==13.0.0 (disabled)
ecommerce==13.0.0 (disabled)
forum==13.0.0 (disabled)
mfe==13.0.1 (disabled)
minio==13.0.0 (disabled)
notes==13.0.0 (disabled)
richie==13.0.0 (disabled)
webui==13.0.0 (disabled)
xqueue==13.0.0 (disabled)

Did you install tutor by downloading the binary? If yes, it is not compatible with 3rd-party Python plugins, such as the ones from the Tutor Wizard Edition (including Cairn). This is the reason why we recently switched to pip install as the default recommended installation.

Once you install from pip, the cairn plugin should be included in the plugins list: Installing Tutor — Tutor documentation

We installed using the AMI Image which I am guessing is the binary. Is there any way to switch to the pip method without taking down the site?

What is the output of the following commands?

which tutor
realpath $(which tutor)
which pip
pip freeze | grep tutor
pip freeze | grep cairn

which tutor/usr/local/bin/tutor
realpath $(which tutor)/usr/local/bin/tutor
which pip/usr/bin/pip
pip freeze | grep tutortutor==13.1.0 tutor-cairn==13.0.1 tutor-monitor==13.0.0
pip freeze | grep cairntutor-cairn==13.0.1

In v13.1.0 of the AMI, Tutor is installed from pypi. Did you upgrade from an older AMI? In any case, you can safely remove the binary and install from pip. Make sure to run the following command as the tutor user:

curl | bash
1 Like