Help needed to update tutor to v3.12.3

Hi @regis

I am running Tutor v3.12.2. I am trying to update to v3.12.3 (to apply the latest edx security patch)

sudo curl -L “$(uname -s)_$(uname -m)” -o /usr/local/bin/tutor

sudo chmod 0755 /usr/local/bin/tutor

After that i run tutor local quickstart

yet when i run tutor – version

I still see Tutor v3.12.2

What am i missing? Thank you.

Hi @nachham,

Can you verify that the updated version of tutor downloaded successfully? Or did curl report an error?

These command should work:

sudo curl -L "$(uname -s)_$(uname -m)" -o /usr/local/bin/tutor
sudo chmod 0755 /usr/local/bin/tutor

You try stopping and restarting tutor manually.

tutor local stop
tutor config save
tutor local quickstart

@nachham what is the output of which tutor?


Yes , Tutor seems to be downloaded![down|690x183]

I stopped manually, did the rest of the commands and still

Tutor --version= tutor, version 3.12.2


Here is the output:

ubuntu@ip-**0***0*:~$ which tutor

Thank you

You have two tutor binaries installed on your computer. One is in /usr/local/bin and the other is in /home/ubuntu/.local/bin. You probably installed the latter with pip install. I suggest you keep only the latter and get rid of the binary release:

sudo rm /usr/local/bin/tutor

And then upgrade the pip-installed version:

pip install --upgrade --user tutor-openedx

Hi @regis

Worked like a charm!