Development Build stuck at create user

I ran the below command for creation of the development image.

tutor images build openedx-dev

I ran tutor local stop before running the above command.

But the build process has taken over 4 hours. The Production build was quick[tutor local quickstart] and is working fine.

Below is my log:

Building image
docker build -t /home/machine/.local/share/tutor/env/build/openedx-dev --build-arg USERID=1000
Sending build context to Docker daemon  5.632kB
Step 1/11 : FROM
 ---> 4e83d402b431
Step 2/11 : MAINTAINER <>
 ---> Using cache
 ---> ab86cbe8487e
Step 3/11 : RUN apt update &&     apt install -y vim telnet     && rm -rf /var/lib/apt/lists/*
 ---> Using cache
 ---> 6cdbaa38645e
Step 4/11 : RUN pip install -r requirements/edx/development.txt
 ---> Using cache
 ---> 39e71c2bff12
Step 5/11 : RUN pip install ipdb==0.12.2 ipython==5.8.0
 ---> Using cache
 ---> 014cec4bd517
Step 6/11 : RUN rm -r /openedx/staticfiles &&     mkdir /openedx/staticfiles &&     openedx-assets webpack --env=dev
 ---> Using cache
 ---> 752e39197dfd
Step 7/11 : COPY ./bin /openedx/bin
 ---> Using cache
 ---> ccb0d4bf5d2a
Step 8/11 : RUN chmod a+x /openedx/bin/*
 ---> Using cache
 ---> 8fd152d4cbca
Step 9/11 : ARG USERID=1000
 ---> Using cache
 ---> dc04a982062b
Step 10/11 : RUN $USERID

 ---> Running in e6215f4a433c
Creating 'openedx' user with id 1000

@shashi.kiran This might be helpful.

Thanks for the reply. I did try tutor images build --build-arg USERID=0 openedx-dev but it was taking old USERID. May be i had to remove existing images and rebuild.

For the moment i have modified to not use chown. This file would be in the tutor root path

@shashi.kiran can you please answer those questions?

  1. What is your operating system?
  2. What version of tutor are you running? EDIT: it looks like you are running v3.12.3, which is the latest release.

Thanks for responding. Below are the answers to your questions:

  1. OS - Ubuntu 18.04.4 LTS
  2. Version of Tutor - 3.12.3

@shashi.kiran would you mind filing a new bug on github?

Title should be something along the lines of “Creating ‘openedx’ user takes too long when building openedx-dev image”.

Please link to this conversation and add as much information as possible about your hardware and operating system.

Will do the needful.

The issue has been created on Github. Sharing it here for reference of other forum members.

With regards,
Shashi Kiran G M