Branch not found error

Hey there, first of all, I want to thank you for the tutor option of installing open edx. I have tried the native installation before I came across tutor, and it was just pain.

However, when running the “tutor images build openedx” command in the indigo theming guidelines, I run into the following error:

  Could not find a tag or branch '01ec2a161dfc3465f9d35b9211ae790177418316', assuming commit.
  Requested django-oauth-plus==2.2.9.edx-1 from git+ (from -r requirements/edx/base.txt (line 15)), but installing version None...

This has made it impossible for the build to complete.

Plus, how can I apply the indigo theme for the production open edx instead of localhost?

Your help will be greatly appreciated.


Hi @dkay! Can you please post a more complete stacktrace of the error?

I do not understand this question.

I noticed that you also posted the same question on the original Indigo topic: please don’t do this. It clutters the topics and you will not get an answer more quickly.

Sorry about that post on the previous topic, and that will not happen again. The image below shows the screenshot of the error stacktrace:

As for my question about applying indigo for the production instance, I tried setting the indigo them for a lms domain instead of localhost, and I was getting n error.

I don’t see any error that is stopping the build process here. (next time please copy-paste the content instead of posting screenshots, it’s much more convenient for us to investigate)

That’s a different problem. Please attempt to resolve only one issue at a time, otherwise it makes things much more confusing.

I am sorry for all the mess that am presenting. It’s my first time here, and I really appreciate the advice that you’re giving me.

Below is the stacktrace of the error that I am getting, I hope this will throw some insight into the cause of the problem.

This is the best I could present since when I tried posting the bigger portion of the stacktrace, I could not post more than 2 links.

The rebuild process gets stuck at Step 19/52.

Step 19/52 : RUN pip install -r requirements/edx/base.txt
 ---> Running in ce7c38c9140b
Obtaining file:///openedx/edx-platform/common/lib/calc (from -r requirements/edx/base.txt (line 8))
Obtaining file:///openedx/edx-platform/common/lib/capa (from -r requirements/edx/base.txt (line 9))
Obtaining file:///openedx/edx-platform/common/lib/chem (from -r requirements/edx/base.txt (line 10))
Obtaining file:///openedx/edx-platform (from -r requirements/edx/base.txt (line 26))
Obtaining file:///openedx/edx-platform/common/lib/safe_lxml (from -r requirements/edx/base.txt (line 33))
Obtaining file:///openedx/edx-platform/common/lib/sandbox-packages (from -r requirements/edx/base.txt (line 34))
Obtaining file:///openedx/edx-platform/common/lib/symmath (from -r requirements/edx/base.txt (line 35))
Obtaining file:///openedx/edx-platform/openedx/core/lib/xblock_builtin/xblock_discussion (from -r requirements/edx/base.txt (line 36))
Obtaining file:///openedx/edx-platform/common/lib/xmodule (from -r requirements/edx/base.txt (line 40))
Obtaining acid-xblock from git+ (from -r requirements/edx/base.txt (line 7))
  Cloning (to e46f9cda8a03e121a00c7e347084d142d22ebfb7) to /openedx/venv/src/acid-xblock
  Could not find a tag or branch 'e46f9cda8a03e121a00c7e347084d142d22ebfb7', assuming commit.
Obtaining codejail from git+ (from -r requirements/edx/base.txt (line 11))
  Cloning (to a320d43ce6b9c93b17636b2491f724d9e433be47) to /openedx/venv/src/codejail
  Could not find a tag or branch 'a320d43ce6b9c93b17636b2491f724d9e433be47', assuming commit.
Collecting crowdsourcehinter-xblock==0.1 from git+ (from -r requirements/edx/base.txt (line 12))

After cloning the indigo theme into the /home/ubuntu/.local/share/tutor/env/build/openedx/themes directory, and rendering the theme, my attempt to rebuild the openedx docker image (using “tutor images build openedx”) yields the above error.

It keeps throwing that error of “could not find tag or branch”, and this goes on forever and the build never comes to an end.

Any idea of what could be the cause of this?

Sorry for all the inconveniences I am causing you.

This is not an error. The fact that the build never comes to an end probably comes from your internet connection. Or maybe Github is partly unavailable for you. I suggest you try again at a later time or from a different server.

1 Like


Thanks @regis