Wagtail Tutor plugin ready for use!

Hi there!
I just tried Wagtail plugin both in Tutor local and on Kubernetes, and it’s works properly. If someone wants to use that, here is the GitHub repo : https://github.com/murat-polat/tutor-wagtail
Why Wagtail?
Because it’s Django CMS, fully customizable and it’s like WordPress :slight_smile:

Best regards,


Congrats on releasing this plugin @qali!

Thanks @regis
I hope can be useful for someone :slight_smile:

Hi @qali

Thanks for this plugin. Can I use wagtail to make a marketing front-end and connect it with tutor ?

Of course @nadheemabdulla, everyone can use it. I just upgraded it to Koa :slight_smile:

Thanks a lot… :heart_eyes:

Can we integrate it with tutor to list courses and share login sessions ?

Can you please tell me how to add Wagtail subdomain to your " /etc/hosts " file as mentioned in the doc ?

After installation

pip3 install -e tutor-wagtail

the plugin is not listed. I tried a server restart

tutor local start -d

still not listed.

Please try it on your local Ubuntu machine first.
I mean reboot your PC, you should see your custom plugins list. Like screenshot below.

$ pip3 list

Shows also all installed packages on your local Ubuntu machine.

To add your subdomain on your local PC :

$ sudo nano /etc/hosts

Than edit your /etc/hosts file as you see in second picture above, and save it. After

$ tutor local quickstart

Choose y for production mods, so you can see wagtail.yourdomain.com

On cloud provider(production server), you must add A record for your subdomains.

1 Like

wagtail is installed ! Thanks for help!

but local quickstart gives the following error

django.db.utils.OperationalError: (1045, "Access denied for user 'wagtail'@'' (using password: YES)")

wagtail.domain is on and shows OperationalError at /

Request Method: GET
Request URL: https://wagtail.domain.com/
Django Version: 3.1.4
Exception Type: OperationalError
Exception Value: (1045, “Access denied for user ‘wagtail’@‘’ (using password: YES)”)
Exception Location: /usr/local/lib/python3.8/dist-packages/MySQLdb/connections.py, line 185, in init

Is it your local PC ? or cloud server ?
lets try an other approach, if DNS alias crash etc. After

$ tutor local quickstart

Select n

Are you configuring a production platform? Type ‘n’ if you are just testing Tutor on your local computer [Y/n] n

you should see on wagtail.local.overhang.io/


If there is an other error

pip3 install -e tutor-wagtail

tutor plugins enable wagtail

tutor config save

tutor images build wagtail

tutor local quickstart

You should see migrations after that if not installed properly before …

I’m using cloud server. It’s difficult for me to install in local pc.

You must add A record for wagtail subdomain. And it must be wagtail.YOUR_LMS_HOST
let me explain:
If your domain is solo.io (LMS) your wagtail must be subdomain wagtail. so it will be served on wagtail.solo.io

So you don’t need add your /etc/hosts file… this is just alias for local test on your local PC
if you added A record to your subdomain for wagtail so just remove it on your /etc/hosts file…

Here an example

I am here and waiting :slight_smile:

1 Like

I already configured A record.

Now I’ll remove it from /etc/hosts and try.

Still the same error :frowning_face:

Please try this

tutor local stop

tutor dev stop

tutor local quickstart

tutor local start -d

Needless to say you just remove(edit) your last changes on your /etc/hosts file… Not remove the file…

1 Like

I did just that only

Still the same. Here is the log

In my opinion you getting error due to your custom register form

lms_1            |   File "/openedx/venv/lib/python3.8/site-packages/MySQLdb/connections.py", line 259, in query
lms_1            |     _mysql.connection.query(self, query)
lms_1            | django.db.utils.OperationalError: (1054, "Unknown column 'org_inst' in 'field list'")

and this error effected the other plugins and migrations. So we must try it step to step…
please deactivate your custom register form plugin (crp) and wagtail, than rebuild.

tutor plugins disable wagtail

tutor config save

and your custom reg form plugin

tutor plugins disable crp

tutor config save

rebuild your platform

tutor images build openedx

tutor local quickstart

Than install and activate just Wagtail plugin first please…

1 Like

Thank you @qali for helping out but I followed all these steps, and still got no difference.
Logs here

I didn’t understand. Can you share your domain please just “LMS” ? is your platform working ?


$ docker ps -a

1 Like

I’ve inboxed you the details. Kindly check.

CONTAINER ID        IMAGE                             COMMAND                  CREATED             STATUS                    PORTS                                                NAMES
da37f9a75aad        muratp/wagtail                    "/bin/sh -c 'uwsgi  …"   19 minutes ago      Up 18 minutes             8000/tcp                                             tutor_local_wagtail_1
68613c24278c        overhangio/openedx:11.0.4         "docker-entrypoint.s…"   11 hours ago        Up 18 minutes             8000/tcp                                             tutor_local_cms-worker_1
f22d2acfc56c        overhangio/openedx:11.0.4         "docker-entrypoint.s…"   11 hours ago        Up 18 minutes             8000/tcp                                             tutor_local_cms_1
b121e55f2939        overhangio/openedx:11.0.4         "docker-entrypoint.s…"   11 hours ago        Up 18 minutes             8000/tcp                                             tutor_local_lms-worker_1
2b07739ad62f        overhangio/openedx:11.0.4         "docker-entrypoint.s…"   11 hours ago        Up 19 minutes             8000/tcp                                             tutor_local_lms_1
feeca1c7c993        nginx:1.13                        "nginx -g 'daemon of…"   37 hours ago        Up 18 minutes             80/tcp                                               tutor_local_nginx_1
0dbd2f889528        97c8d2703661                      "/bin/sh -c 'openedx…"   2 days ago          Exited (1) 2 days ago                                                          youthful_greider
ff314d340fea        340a647e82ee                      "/bin/sh -c 'openedx…"   2 days ago          Exited (1) 2 days ago                                                          exciting_bouman
d93a113b21ce        d74fe6bf23c1                      "/bin/sh -c 'openedx…"   2 days ago          Exited (1) 2 days ago                                                          clever_lehmann
65d91f3ae0ee        d74fe6bf23c1                      "/bin/sh -c 'openedx…"   2 days ago          Exited (1) 2 days ago                                                          vigorous_wilbur
41c1d2cee5bc        85e6a02f0d86                      "/bin/sh -c 'openedx…"   2 days ago          Exited (1) 2 days ago                                                          wizardly_curran
083847addb42        813c2e8eef07                      "/bin/sh -c 'openedx…"   2 days ago          Exited (1) 2 days ago                                                          stoic_cerf
03576c3f27bc        overhangio/openedx-forum:11.0.4   "docker-entrypoint.s…"   5 days ago          Up 17 minutes             4567/tcp                                             tutor_local_forum_1
f2002dbc4040        mysql:5.7.32                      "docker-entrypoint.s…"   5 days ago          Up 19 minutes             3306/tcp, 33060/tcp                                  tutor_local_mysql_1
e834a512047a        caddy:2.2.1                       "caddy run --config …"   5 days ago          Up 19 minutes   >80/tcp,>443/tcp, 2019/tcp   tutor_local_caddy_1
c51d082b8a6b        redis:6.0.9                       "docker-entrypoint.s…"   5 days ago          Up 19 minutes             6379/tcp                                             tutor_local_redis_1
06f662930105        mongo:3.6.18                      "docker-entrypoint.s…"   3 months ago        Up 19 minutes             27017/tcp                                            tutor_local_mongodb_1
a958485cc554        namshi/smtp:latest                "/bin/entrypoint.sh …"   3 months ago        Up 19 minutes             25/tcp                                               tutor_local_smtp_1
36465458cc93        elasticsearch:1.5.2               "/docker-entrypoint.…"   3 months ago        Up 19 minutes             9200/tcp, 9300/tcp                                   tutor_local_elasticsearch_1
ebd8293acaba        hello-world                       "/hello"                 7 months ago        Exited (0) 7 months ago                                                        great_babbage
344ba7ee3c17        hello-world                       "/hello"                 7 months ago        Exited (0) 7 months ago                                                        mystifying_stonebraker

will logging into mysql and granting database permissions work ?

Please can you check your domain now ?

1 Like