Translation are not loading

I’m currently developing an application using tutor and we are customizing it to our needs. One thing i’ve been experiencing with translation (and some scss files) is that even though i’m using the following command:

tutor images build openedx

The translations never update locally, is there something i should be doing? deleting files or something like that. I think that when is builds the first time it is generating some files, but rebuilding does not overrides it.

OS: Linux Mint 19.3
Tutor: 10.0.10

You need to stop and start the containers for the new images to be used. You can do so with:

tutor local stop && tutor local start -d

@juansele i’ve been trying this commands as well, but it’s still not working, translations still the same

What is LANGUAGE_CODE in $(tutor config printroot)/config.yml set to?
Where did you create the django.po and djangojs.po files?


The files are stored in $(tutor config printroot)/env/build/openedx/locale/pt_BR/LC_MESSAGES

That seems to be correctly configured. If the build process shows no errors I’m getting out of ideas.
What string are you using to test the changes?

This is a djangojs.po example

and a django.po example

Can you describe more precisely your environment?

  1. What is the file hierarchy in $(tutor config printroot)/env/build/openedx/locale/?
  2. What is the content of the files located there?
  3. What commands are you running exactly?
  4. What page are you loading to view the translations?
  5. What version of tutor and plugins are you running?

I found the problem and it was my mistake. I wasn’t replacing the right files. I have a project with the translation files, and when i changed it inside the project, i was forgetting to change it in my environment. Just changing the content and rebuilding helped resolve this user problem (myself).