Theme not working

Hi, Everything was working fine before I replaced my theme dir with a new one. But then I don’t know how to detect the problem. When I run the development version, It says that

    `2019-11-11 14:41:57,463 ERROR 118 [openedx.core.djangoapps.theming.helpers] helpers.py:225 - Theme not found in any of the themes dirs. [Theme 'my-theme' not found in any of the following themes dirs,
Theme dirs:
[Path(u'/openedx/themes')]]`

But my theme is in the right place, in “$(tutor config printroot)/env/build/openedx/themes”, with right name, so I don’t know what may causing this problem.
I tried reinstalling with quickstart, tried tutor config save, but my theme just don’t take any effect.
Any suggestion on how to sovle this? For me there is only one solution left, reseting my mac :sweat_smile:, which I don’t want to do.

This is from my lms.envs.tutor.development
CERT_QUEUE 'test-pull' CHECKPOINT_PATTERN '(?P<checkpoint_name>[^/]+)' CMS_BASE u'studio.localhost' CODE_JAIL {'limits': {'CPU': 1}, 'python_bin': None, 'user': 'sandbox'} COMMENTS_SERVICE_KEY u'********************' COMMENTS_SERVICE_URL u'http://forum:4567' COMMON_ROOT Path(u'/openedx/edx-platform/common') COMPLETION_BY_VIEWING_DELAY_MS 5000 COMPLETION_VIDEO_COMPLETE_PERCENTAGE 0.95 COMPREHENSIVE_THEME_DIRS [u'/openedx/themes'] COMPREHENSIVE_THEME_LOCALE_PATHS [] CONFIG_PREFIX 'lms.' CONFIG_ROOT Path(u'/openedx/config') CONTACT_EMAIL u'contact@www.myopenedx.com' CONTACT_MAILING_ADDRESS '' CONTENTSTORE {u'DOC_STORE_CONFIG': {u'db': u'openedx', u'host': u'mongodb', u'port': 27017}, u'ENGINE': u'xmodule.contentstore.mongo.MongoContentStore'}

Is the value of COMPREHENSIVE_THEME_DIRS and COMPREHENSIVE_THEME_LOCALE_PATHS right?

Thanks!

Hi @teruun! Did you rebuild the openedx docker image? https://docs.tutor.overhang.io/configuration.html#adding-custom-themes

Thanks for reply, no, I didn’t, I am using only development version, tutor dev runserver lms. It was all right days ago without rebuilding.

You are aware that re-building the image is required, even in development mode, right? That or running watchthemes.

It turns out than I was linking to my theme dir with a soft link, the soft link just don’t work. Thanks for your time :grinning:

1 Like

You’re not the first to bump into this issue, this should probably be part of the FAQ…

Then I will try a pull request on documentation

1 Like