Overhang.io

Studio Login not working

#1

Hello everyone

I created a second topic since this is unrelated to the first one.
I set up an environment inside a Linux VM in Azure.
config.yml is as follows:

ACTIVATE_HTTPS: true
ACTIVATE_NOTES: false
ACTIVATE_XQUEUE: true
CMS_HOST: studio.edx.leex.ch
CONTACT_EMAIL: contact@leex.ch
ID: dWkYQGyq
LANGUAGE_CODE: en
LMS_HOST: edx.leex.ch
PLATFORM_NAME: My Open edX

I’ve omitted some of the secret stuff :stuck_out_tongue:

Now, problem is, for some reason the login into the cms doesn’t work.
By which I mean, that I try to sign into the CMS, get forwarded to the LMS Login system (correct behavior as of Ironwood I think), enter my credentials, but when i then get directed back to the CMS, i’m not logged in.
Once I go back to the LMS, i’m logged in though.

This didn’t happen in an instance, where I had SSL-Encryption not enabled.

Do you know what might cause this problem, and how I might fix it?
If you need access to monkey around, i can provide you with one, since this is only a test enviroment.

#2

Which version of tutor are you running? This should have been fixed in recent releases.

#3

From what I can gather it is version 3.3.3

I checked both github and the “version”-file in the …/tutor/env/-directory

#4

Can you please add SESSION_COOKIE_DOMAIN": ".edx.leech.ch", to lms.env.json, and restart the platform? This looks like a regression. Please open a github issue with your findings, and I’ll fix it when I have access to a computer again.

#5

Done and done.
Thank you for your amazing and quick help.