SSL not enabling

Hi, I have generated SSL certificate using tutor. I restarted nginx but it did not work and SSL is not enabled for my site. I can see certifiate file here /root/.local/share/tutor/data/letsencrypt/live/.
Please assist me if I missed any step?

Hi @sajid! :wave:

How did you do that?

Again, how did you do that?

What do you mean? Do you mean that the website is still running with http? or that the website does not respond?

Do we all agree that you are running tutor as root and this is a bad idea?

Hi @regis, sorry for the late reply.

  1. I generated SSL cetificate using tutro with following commands.
    tutor local stop nginx
    tutor local https create

  2. I restarted nginx using following command
    tutor local start nginx --detach

  3. Yes website is still running with http.

  4. Yes I am running tutor as root.

You must restart your entire Open edX platform to take into account the new changes. Please simply run tutor local quickstart, and when asked whether you want to enable https, type “y”.

Thank you @regis for your reply. My team has achieved it in different way. Please find the step that they did

  1. Stop nginx
    tutor local stop nginx

  2. Issue certificate
    docker run --rm -it --volume /root/.local/share/tutor/data/letsencrypt:/etc/letsencrypt/ -p 80:80 --entrypoint=sh docker.io/certbot/certbot:latest -e -c certbot certonly --standalone -n --agree-tos -m admin@mydomain -d mydomain -d mydomain

  3. Modify docker-compose.yml file locate in /root/.local/share/tutor/env/local to mount /root/.local/share/tutor/data/letsencrypt to /etc/letsencrypt directory in nginx container.
    Screenshot is attached.
    download (1)

4.Configure lms and cms to enable SSL.
These file are located in /root/.local/share/tutor/env/apps/nginx

After this I build nginx and restarted and it enabled HTTPS on my websites.

Please suggest me if it was the correct way?

I don’t really know what to tell you… There are hundreds of people who have successfully enabled HTTPS simply by running tutor local quickstart, so I’m not sure I understand why you need to go through all these troubles…

Maybe this was not clear from the start, but Tutor takes care of generating SSL certificates for you and properly configures all services to use SSL. All you need to do is to type “y” in the interactive SSL configuration step during quickstart.

Yes @regis this was not clear from start.

Would you like to clarify the docs or the instructions that are printed during quickstart in any way?