SAML authentication not working

I’ve been trying to get SAML authentication working for several days. Despite following the instructions very carefully, something just isn’t working.

I used the Tutor installation instructions to install from source, which begin with these commands:
git clone
cd tutor
pip3 install -e .

For SAML authentication, I followed the instructions under “Enable SAML Authentication” here:

I found an error in the instructions. I figured out that the line beginning with “SOCIAL_AUTH_SAML_SP_PRIVATE_KEY” needs a comma at the end, but once I corrected it, I was able to enable the plugin (tutor plugins enable saml), update my configuration (tutor config save), and start Tutor (tutor local quickstart).

I worked with my Enterprise Authentication Team to help me fill in the Provider Configuration (SAML IdPs), SAML Configuration, and SAML Provider Data portions of the LMS administration page.

Unfortunately, the login page still shows only Email and Password prompts.

I saw the post on this site that says the slug needs to be “default”, but that didn’t help in my case, and when I search for help on Google, the word “tutor” is being interpreted as “tutorial,” so I’m seeing lots of tutorials for lots of things, but so far, none have been about Tutor software.

I am the administrator of the Ubuntu 20.04 machine on which I’ve installed Tutor, so I can provide lots of information, though at this point, I’m not sure what would be helpful.

Can anyone help?


After many more hours of work, I finally found an answer. I changed many things along the way, so it’s difficult to say for sure which change(s) made the difference. I’m just happy to report that it’s working now.

Thanks for confirming that it works! We tried to get it work a while back, but had problems and never got back to looking at it.

You mentioned one site that you used:

But, you mentioned that other settings:

My team told me the same, as you described:

Do you have a reference to the web page that contans the instrutions that worked for you?