Run mfe locally without devstack

I need to run mfe locally without running devstack on my machine to avoid extra load on my machine. I have my mfe running at localhost and lms on server.But facing this error related to cookies .

NewRelicLoggingService.js?484b:35 Error: Access token is still null after successful refresh.
    at _callee$ (webpack-internal:///./src/auth/AxiosJwtTokenService.js:140)
    at tryCatch (webpack-internal:///./node_modules/babel-polyfill/node_modules/regenerator-runtime/runtime.js:68)
    at Generator.invoke [as _invoke] (webpack-internal:///./node_modules/babel-polyfill/node_modules/regenerator-runtime/runtime.js:299)
    at Generator.prototype.<computed> [as next] (webpack-internal:///./node_modules/babel-polyfill/node_modules/regenerator-runtime/runtime.js:121)
    at asyncGeneratorStep (webpack-internal:///./src/auth/AxiosJwtTokenService.js:10)
    at _next (webpack-internal:///./src/auth/AxiosJwtTokenService.js:12) Object

Have you changed the env file to point to your local instance of tutor? You will probably have to change the “ALLOWED_HOSTS” in your Open edX config too,

Also, you are trying to do it the “devstack” way, the more “tutor” way would be to run tutor local dev, and specifically the dev container of your mfe (e.g. profile-dev) and then bind-mount your local repo into it the container. (I haven’t tried it yet myself but I’m planning to)

Thanx for replying but i had some queries still
1-where do we need to add ALLOWED_HOSTS
2-I have set tutor up on web and i want to connect my mfe to to web tutor and the error which i am facing is regarding cookies that my localhost is not able to access cookies of openedx/tutor on web.
After some research I found that https cookies are not shared to http request.
any thoughts on that?

Are you trying to run an MFE locally with an instance of tutor running on a server? Is that how you were running it with devstack? If so that’s interesting, I haven’t tried that!

Yes that’s what we tried . The only error we facing is cross domain cookie setting. For example is not able to read or access cookies of tutor instance on server.

Is there anything stopping you from running tutor on your machine?

It’s a lot less resource hungry than devstack and it would make the setup easier.

Yeah, It will make it easier but was trying something else to minimise my machine usage as much as possible. So any thoughts on that cookies error which i am trying to explain like cookies between https:localhost and https ???

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.