Plugins Install .yml doesn't seem to work

So I am trying to install a simple plugin but using the URL method mentioned in the docs does not seem to work.

I am in the webui and I run
plugins install

I get the error

Usage: tutor [OPTIONS] COMMAND [ARGS]...
Try 'tutor -h' for help.

Error: No such command 'ui'.

This error has been bugging me for a long time… I attempted to fix this issue in tutor-webui 12.0.2. Can you please upgrade and see if it works for you?

curl | bash

I get a different error now

tutor plugins install
Traceback (most recent call last):
  File "", line 24, in <module>
  File "tutor/commands/", line 30, in main
  File "click/", line 1128, in __call__
  File "click/", line 1053, in main
  File "click/", line 1659, in invoke
  File "click/", line 1659, in invoke
  File "click/", line 1395, in invoke
  File "click/", line 754, in invoke
  File "tutor/commands/", line 131, in install
PermissionError: [Errno 13] Permission denied: '/home/tutor/.local/share/tutor-plugins/allowedemail.yml'
[7309] Failed to execute script 'main' due to unhandled exception!

should I run with sudo? I am the tutor user

It seems that you don’t have write access to the plugin folder.
What is the output of ls -l /home/tutor/.local/share/tutor-plugins/allowedemail.yml?

I mus have originally created the folder with the ubuntu account. I deleted the folder using sudo and then recreated it with the tutor account. It then said the plugin successfully installed.!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.