No "Course visibility" entry in 13.2.2

The [seo.enable_anonymous_courseware_access] Waffle flag seems to work in Tutor 13.1.11 but not in 13.2.2 (or 2.0 and 2.1 for that matter). The only difference I can find is that 13.1.11 has MFE plugin 13.0.2 while 13.2.2. uses MFE plugin version 13.0.4. Is this relevant? Any ideas about what can cause this problem?

Thanks in advance,
Helge Hoivik

It worked for me after I cleared the cache:

tutor local run lms ./manage.py lms shell -c "from django.core.cache import cache; cache.clear()"

Thanks for feedback and suggestion. I did a clean install and flushed the cache.
Same result …
Any further hints?
Thanks in advance!

Helge

This is the environment for the recent test installations. I run Ubuntu update & upgrade before installation and follow the instructions at Releases · overhangio/tutor · GitHub

@helgeh I moved your last post here to keep the conversation focused.

  1. What is the output of tutor --version?
  2. What is the output of tutor plugins list?
  3. What are the exact urls where the error is occurring? (both of them)
  4. Since there seems to be some kind of error client-side, is there anything that is printed in the browser developer console? Please also add a screenshot of the network tab.

When possible, please copy-paste error messages and stacktraces, and avoid screenshots. This makes it easier for other people with the same issue to google the solution.