Multiple Install Issues Using AWS image

  1. “UI” issue - When I first installed tutor and accessed the webUI as reccomended on the youtube video. I was presented with an error “Error: No such command ‘ui’.” I figured out that I can just SSH into the machine, sudo su tutor, then run tutor local quickstart.

  2. a3.medium AWS instances lock up around the “enterprise” migration step and will not complete. I was able to get this working with an a3.large, but considering the low volume of students we are expecting, it’s unfortunate we have to use a larger instance than we really need.

  3. Even after correctly setting my DNS I cannot use my preferred hostnames. I setup an A record for kazooacademy. com and a CNAME for *.kazooacademy. com that points to kazooacademy. com. However, I got SSL cert warnings when I did tried to use kazooacademy. com as my lsm site and studio.kazooacademy. com as my studio hostname. I also tried lsm.kazooacademy. com and studio.kazooacademy. com. Same issue. Only lsm.kazooacademy. com and studio.lms.kazooacademy. com will work.
    (sorry for the extra spaces before the .com, the site didn’t like that I had so many “links”)

It seems like we are up and working now, though not on our preferred hostnames and not on our preferred instance type. Just wanted to share our experience. If you want to target non-technical folks eventually, you might want to clean up some of these edge cases :slight_smile:

Thanks for the report @RickG!

This issue should now be fixed in v12.0.4. Please upgrade by running: curl | bash -

This is correct. This is the reason why t3a.large is the recommended instance type for the Tutor AMI.

This is not supposed to happen. Can you please run tutor local quickstart, configure the domain names, and then paste here the logs from the Caddy container:

tutor local logs --tail=100 caddy

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.