MFE not running by default on development start. Documentation error?

I installed tutor on a new laptop and followed the docs to install it. After running tutor local quickstart and importing the demo course, everything ran fine.

However, I then started the development server. I followed the instructions from here: Open edX development — Tutor documentation

I ran tutor local stop and then tutor dev dc build lms. After the images built, I ran tutor dev runserver lms.

Everything seemed to work until I tried to resume the demo course, in which case I received a 404 error on the URL:

http://apps.local.overhang.io:2000/learning/course/course-v1:edX+DemoX+Demo_Course/home

Looking at the docker containers that are running, the mfe container is not present.

I think that the documentation needs to be upgraded to explain this, or the image should be started with the development server.

1 Like

So for anyone else that stumbles upon this post, you will need to either:

  1. Disable learning MFE - Disabling the Learning MFE in Maple (slightly misleading documentation) - #7 by juhityagi - DevOps - Open edX discussions
  2. Run tutor dev runserver learning in a separate terminal.

I’m not sure how this could / should be added to the docs but it is not obvious.

Thanks for reporting this and documenting your workaround @ToddLichty.

It’s on our radar to fix this in a future Tutor release by deprecating the tutor local runserver command in favor tutor local start, the latter of which starts all installed services (including the mfe container) by default. There’s a ticket for it here if you are interested in following along.