Lms.env.json and cms.env.json files not found


I am a beginner here. I would like to know where are lms.env.json and cms.env.json files located? I tried going to /edx/… but such a directory is not there . I tried checking in /home/ubuntu but the folder is empty. Please help me if you don’t mind.

folders in root

bin home lib64 opt sbin tmp vmlinuz.old
boot initrd.img lost+found proc snap usr
dev initrd.img.old media root srv var
etc lib mnt run sys vmlinuz

The *.env.json files are generated in the ~/.local/share/tutor/env folder and mounted inside the docker containers at runtime. If you really want to modify those files, I suggest you learn about how Tutor and Docker work:


Thank you!
I’ll try to learn this.
I would like to generate certificate, which is why I wanted to edit those files.

@nadheemabdulla did you find any workdaround to update lms.env.json file?

@regis I’m did not find any way to persist updated lms.env.json file. I want to add “ALLOW_PUBLIC_ACCOUNT_CREATION” : false in lms.env.json file every time I add qucikstart command remove it. any suggestion ?

Use a plugin and follow the Tutor documentation for its configuration.

@ak00001 can you please provide little more details? Documentation link or example plugin.

@aleem https://docs.tutor.overhang.io/plugins.html#plugins

Use this forum to search for how other people have used the YAML and python plugins :slight_smile:

@ak00001 I followed this guide and created a plugin but seems like plugins only update existing config keys not add new configuration key.
I want to add ALLOW_PUBLIC_ACCOUNT_CREATION in both lms.env.json and cms.env.json file.
any suggestion ?

@regis @ak00001
I want to disable public registration on openedx for that I have to set this flag as false. I tried this with below mentioned plugin but did’nt seems to be working

name: custome_cms_evn
version: 0.1.0
  openedx-cms-settings: |

can you please help point out error or provide correct code

You’re almost there. This flag should be added both to the lms and cms list of features:

name: custome_cms_evn
version: 0.1.0
  common-env-features: |

@regis thanks a lot. it worked. :+1: