LMS and webui are available but CMS is not


I just installed open edx via tutor. It went pretty quickly at first, and I got an LMS which I (and you) can reach at:

and a webui at the above + “:3737”

However I cannot browse to my CMS, which I configured (in tutor) to be at:


Once that is running I figure I can start actually creating a course, but I am stuck on this step.

I have not done any DNS server configuration on this server. Is that needed? I would much appreciate clear instructions.

Many thanks,


Hi @samuelflores,
Yes you need two A record for Studio and Preview(not sure) in your DNS configurations.

Actually, it is recommended to define a CNAME DNS record to point all “*.LMS_HOST” subdomains to “LMS_HOST”. This is explained in this video: https://www.youtube.com/watch?v=xtXP52qGphA

I guess it would make sense to add this information to the installation docs…

EDIT: the required DNS records were added to the docs: https://github.com/overhangio/tutor/commit/a1858989774070f375ecb175d64bdcf9c75c8b45

Hi Regis and others,

Thanks for your replies. I guess I should clarify – bioinfo1.scilifelab.se is not a cloud server, it is a physical 32-core machine at our facility in Solna, Sweden.

Our IT-support team rather quickly set studio.bioinfo1.scilifelab.se to point to bioinfo1.scilifelab.se . However that does not seem to fix the problem, my browser says:

This site can’t provide a secure connection

studio.bioinfo1.scilifelab.se sent an invalid response.


I read Regis’s new comments on github, but I think what IT-support did, covers that and am still stuck…


Looks like it’s working now :slight_smile: https://studio.bioinfo1.scilifelab.se/ It takes a minute or two for Caddy to attempt certificate renewal after it has failed once.

Ah yes indeed! Many thanks! I will now try to get a first course running.


i am facing same server after i have deployed tutor based open edx on my server, this is an internal server only and not accesible from outside. however, i get same error. i have created a records and cname to point to the lms host.


here are my dns records pointing to the server ip


Hi @tabrezgoilkar ,
Normally I’m doing like this:

  • Adding domain name to my server, which points my server IP and it’s will be LMS name.
  • Adding A record for preview
  • Adding A record for studio


tutor local quickstart

LMS name : mydomain.com
CMS name: studio.mydomain.com

If your LMS name is elearning.mydomain.com your studio will be studio.elearning.mydomain.com

You should not use SSL/HTTPS for internal testing. imo.


actually its not internal testing more we want to implement it in our organization internal team as production

can i remove ssl/https with quick wizard instead of reinstallation complete instance?

I think It’s good idea to remove SSL/HTTPS for now, just see if it works properly. If your organization has already SSL cert, your Tutor platform will be subdomain of your organization, I think SSL settings may be different ?

yes i removed ssl and its working fine. yes we already have ssl certificate and i am trying to find documentation to replace letsencrypt certificate with our own.

probably issue here which i understand from logs is that lets enecrypt certificate will only work if public dns record is available for your lms and cms and also its trying to authorize through lets encrypt server so if its internal server and firewal rules are blocking external traffic than it wont work i guess

1 Like

Actually I’m not sure,
but according to this paragraph Configuration and customisation — Tutor documentation, Caddy proxy generating SSL via Letsencrypt. If you select SSL “yes” after quickstart, is it working ?(HTTPS)
Can you try it, just for testing purposes ?

no if select ssl yes it doesn’t work

OK. Thanks.
I found this example Common Caddyfile Patterns — Caddy Documentation . May be you can try to make a YML plugin ( Getting started with plugin development — Tutor documentation ) with this parameter to the Caddyfile ?

thanks i will look into it

Hello @samuelflores, I would be happy to make a walk-thru’ on how to set up and run Open edX with Tutor. Our Dean of Innovation in Health Sciences and other colleagues at Oslo Metropolitan University are probably also interested in contact and cooperation on the topic itself (Bioinformatics).

We have set up a short edX-course that explains how to do so (blended mode) in Norwegian at PISA-3 Installasjon og drift | uhX. Feel free to use it as you would like according to the Create Commons licence ATTRIBUTION-NONCOMMERCIAL-SHAREALIKE.

Helge Hoivik (professor, elearning and digital documentalism, OsloMet)