Issue with redirect to HTTP on 'Sign in' in Studio

I deploy Tutor (olive.1) in Kubernetes. I build the project with HTTPS enabled globally (The argument “ENABLE_HTTPS: true” is defined in the global configuration file ~/.local/share/tutor/config.yml). In general I’ve no issues with using HTTPS in the project except authentication in Studio.
For example if I go to the studio url “” and click on the “Sign in” button it sends me to the url “”. As you can see it redirects me to HTTP instead of HTTPS in the “next=”.
Can you please help me to fix this problem? I tried to rebuild the project again with “ENABLE_HTTPS: true”. I checked there’re no references to “http://” in the ~/.local/share/tutor/env/apps/openedx/settings/cms/, ~/.local/share/tutor/env/apps/openedx/settings/lms/ files.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.