Is "tutor images build openedx" not cleaning up after itself?

I ran “tutor images build openedx” once and it succeeded. I ran it again, and it failed due to out of space error on my amazon AMI. I went searching for what’s taking up all my space, and the answer is:

47G /var/lib/docker

88K /var/lib/docker/buildkit
31M /var/lib/docker/containers
106M /var/lib/docker/image
128K /var/lib/docker/network
40G /var/lib/docker/overlay2
16K /var/lib/docker/plugins
4.0K /var/lib/docker/runtimes
4.0K /var/lib/docker/swarm
4.0K /var/lib/docker/tmp
4.0K /var/lib/docker/trust
3.8G /var/lib/docker/volumes

Is this expected? Is there something I need to do to purge unneeded docker images?

Do I (and really everyone) need to run “docker system prune -a” after every “tutor images build openedx”?

I’ve noticed this behaviour as well. After building images 3 or 4 times, I wind up running docker system prune -a just to recover disk space.

It really depends how much disk space you have, and how frequently you re-build Docker images. On the demo server, which has a 158Gb disk, I hardly ever need to prune the Docker images.

OK, but the recommended storage size here is 25GB:
https://docs.tutor.overhang.io/install.html?highlight=tutor%20upgrade%20version

and IIRC (it’s been a while) the amazon AMI started with 20GB (before I upgraded it to 40, before I upgraded it to 60, before I realized I need to prune, and now it seems to be stable around 18GB storage used.)