Installing edx_xblock_scorm

Hi Team,

Thanks for your help with this.
I have been trying to install a scorm xblock for a couple of days now.

My steps are as follows:

echo “git+https://github.com/raccoongang/edx_xblock_scorm.git” >> “$(tutor config printroot)/env/build/openedx/requirements/private.txt”

and if I

cat $(tutor config printroot)/env/build/openedx/requirements/private.txt,

I can confirm the following:

git+https://github.com/open-craft/xblock-poll.git
git+https://github.com/raccoongang/edx_xblock_scorm.git

However, I am not sure though, if according to https://github.com/raccoongang/edx_xblock_scorm, the second entry should be:

git+https://github.com/raccoongang/edx_xblock_scorm.git#egg=edx_xblock_scorm

rather than

git+https://github.com/raccoongang/edx_xblock_scorm.git

After that, I run

tutor images build openedx

and

tutor local quickstart

My advance modules list is:

> "poll",
>  "survey",
>  "scromxblock"

But still can’t see the scorm under advanced, I can see Poll though. Please help. Thanks

PS: sorry not sure how to check if the tutor version is based on Ironwood or not but when I

tutor –version returns

tutor, version 3.11.5

Hi ire,
git clone https://github.com/raccoongang/edx_xblock_scorm.git
sudo mv edx_xblock_scorm “$(tutor config printroot)/env/build/openedx/requirements/”
echo " -e ./edx_xblock_scorm/" >> private.txt
tutor images build openedx

May be you need to change studio(cms)/settings/advanced settings/ than " Course Visibility For Unenrolled Learners" : “public” after that “tutor images build openedx” and " tutor local quickstart".

God Luck!