Install latest version of xblock on openedx

Hi! I deployed a production version of Open edX on my Azure VM. I want to update the Xblock version followed this link: Configuration and customisation — Tutor documentation. And when I run
tutor local quickstart, I got some error like this:

ERRORS:

xblock_config_courseeditltifieldsenabledflag: (models.E028) db_table ‘xblock_config_courseeditltifieldsenabledflag’ is used by multiple models: xblock_config.CourseEditLTIFieldsEnabledFlag, lti_consumer.CourseAllowPIISharingInLTIFlag.

It seems the old version and new version have some conflict. Is it possible to fix this problem? Or is there any way to change some Xblock code on tutor? Thank you very much!!

2 Likes

Hi,

I have met the same problem. Expect that someone will come to our aid.

By the way, I also want to ask that how can I modify the source code of edx-platform and xblock-lti-consumer using the development mode of tutor?

Thank you very much.

2 Likes

Hi @Yanke! I do not observe the same error. Please describe precisely the steps that I should follow to reproduce your issue.