Install figure errors

When installing Figures on tutor I get the following error in the enable command

User@server :~$ sudo tutor plugins enable figures
Traceback (most recent call last):
  File "/usr/local/bin/tutor", line 11, in <module>
  File "/usr/local/lib/python3.6/dist-packages/tutor/commands/", line 37, in main
  File "/usr/local/lib/python3.6/dist-packages/tutor/commands/", line 121, in add_plugin_commands
    for plugin in plugins.iter_installed():
  File "/usr/local/lib/python3.6/dist-packages/tutor/", line 236, in iter_installed
    yield from Plugins.iter_installed()
  File "/usr/local/lib/python3.6/dist-packages/tutor/", line 203, in iter_installed
    for plugin in PluginClass.iter_installed():
  File "/usr/local/lib/python3.6/dist-packages/tutor/", line 105, in iter_installed
    yield cls(entrypoint)
  File "/usr/local/lib/python3.6/dist-packages/tutor/", line 95, in __init__
    super().__init__(, entrypoint.load())
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 2323, in load
    self.require(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 2346, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 783, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (setuptools 39.0.1 (/usr/lib/python3/dist-packages), Requirement.parse('setuptools>=40.3.0'), {'google-auth'})

I’m curious if there is a missing dependency I have not enabled yet and why google auth?

please reboot your PC or server try it again

$ tutor plugins list

you should see that ??

What i get when looking at that is the same error string again.

Yes It’s strange, why google auth?.. Did you tried

pip3 install setuptools ?

no I haven’t yet going to try a reset then re-enable see if that gets me anywhere as all the commands then resulted in the same error

Hi again,
I have just tried tutor-figures , and got this error:


I believe tutor-figures incompatible tutor-openedx >10.0.0 … Now I’m using 10.2.4… and new release coming soon, if I understand correctly…

well that makes sense thank you

There is a PR out now to make Figures compatible with Juniper, so keep an eye on the project. Hopefully it will be compatible soon.