HTTPS behind Reverse Proxy

Hello everyone,

I’m trying to run Open edX without Caddy and using another Reverse Proxy.
I’m able to access the pages of the CMS and LMS, but the CMS login is not working.

Error: invalid_request Mismatching redirect URI.

I’m getting a 400 Bad Request in the authorize request from CMS to LMS.
I noticed that redirect_id is not using https, but http.
Screen Shot 2022-05-21 at 20.02.37

My configuration about this URL is correct, I can confirm in Django Admin:

Is there other place to config that?

I believe the HTTPS part is your problem, you can confirm by changing the URL in DjangoAdmin to HTTP.

Take a look at this configuration value: Search · ENABLE_HTTPS · GitHub
You might have missed some configuration that depends on this value.

Also, please note that this Discussion forum will not be used anymore. Here is the notification from Régis in case you missed it.

Please do not open new topics here :warning:

Since Tutor is now the default recommended community installation for Open edX, this forum is merging with the official Open edX forum hosted at https://discuss.openedx.org. As a consequence, all conversations related to Tutor should now be held there. You are encouraged to add the “tutor” tag to all new topics that are specific to Tutor.

This forum will remain available as a source of reference for all previous conversations, but it will no longer be actively monitored.

I would like to give a big warm :heart: THANK YOU! :heart: to all the users who have contributed to this forum and made it a welcoming, deeply useful source of information for the entire Open edX community. This forum has been an integral part of my life for the past three years. I’m excited to see what lies ahead!

The proxy needs to add the X-Forwarded-Proto (and X-Forwarded-Host, X-Forwarded-For) headers to every request. Because the configuration depends on which proxy you’re using, the implementation is left as an exercise to the reader.

Thank you for the help.

@uetuluk I already took a look at ENABLE_HTTPS in the tutor code.
@regis The proxy already has these headers.

I’ve spent two days with this and I posted here to see if somebody already had his problem …
The weird thing is the other navigations are working and the Django admin has the right value.

Is an option to disable the users to create new topics here? Allowing only answers.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.