How to permanently disable webui?

The amazon AMI comes with the webui plugin installed by default, but then somehow it doesn’t behave like a normal plugin which shows up with “tutor plugins list” as one would expect based on the installation instructions here: (which I assume are used with non-AMI installs.)

I.e. for a fresh new AMI I see:

tutor plugins list
discovery==11.0.1 (disabled)
ecommerce==11.0.1 (disabled)
license==11.0.0 (disabled)
minio==11.0.0 (disabled)
notes==11.0.0 (disabled)
xqueue==11.0.1 (disabled)

So webui’s definitely there and on, but it’s not listed so it can’t be disabled through that mechanism. I’d like to do the equivalent of “tutor plugins disable webui”, so that it’s permanently off and doesn’t restart on quickstart or anything like that. How can this be accomplished on AMI installs?

Actually, maybe it doesn’t matter now? I just upgraded to tutor 12.0.1 and Lilac, and it looks from the changelog like webui isn’t installed by default anymore, and nothing seems to be listening on port 3737, so maybe I’m fine in tutor > 12 in terms of it not running anymore?

Yes, this is correct. WebUI was moved to a separate plugin in Tutor v12. In Tutor v11, with the AMI, you could explicitely stop the webui with sudo systemctl stop tutor-webui.

Would that permanently stop it though? Or would it restart the next time quickstart is run?

With sudo systemctl stop tutor-webui the Web UI will be restarted next time the server is restarted. To completely remove it, you should run (I believe):

sudo systemctl disable tutor-webui

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.