Having an issue with webpack config when developing

I am having an issue when developing MFEs which is slowing me down a bit.

Essentially when I map the MFE source to a local folder using the docker-compose.override.yml file than the container fails to start with this text.

> @edx/frontend-template-application@0.1.0 start /openedx/app

> fedx-scripts webpack-dev-server --progress

Running with resolved config:


No local module configuration file found. This is fine.

✖ 「wds」: webpack Dev Server Invalid Options

options.allowedHosts should be {Array} (https://webpack.js.org/configuration/dev-server/#devserverallowedhosts)

The default dev webpack.dev.config.js file isn’t being used/mapped in this scenario.

I even copied this file to my development location but I got the same error.

Not using the override grabs the code from github and works fine.

Anyone have any tips to solve this. This does slow us down as we like to develop with the MFE in a container so we can catch/solve any issues before pushing up to our git.


Did you create your fork on top of the master branch or the actual release? It should be the later. If you run on master, then you will need to install webpack 4, and then you will run into the issue that is indicated by this comment: tutor-mfe/webpack.dev.config.js at 0ed49fe7c66be380236276642ad1f5778bf5eb11 · overhangio/tutor-mfe · GitHub

I managed to solve this by updating the frontend-platform component to a 9xx one along with other components. Than it worked just fine.