Error with MySQL initialisation

Hi there,

I have this error when running tutor local quickstart. (Check screen shot below)
Not sure what is IP It doesn’t exist on my local.
By the way, the local server is using IP
Do you guys have any idea to fix this?

Hi @phucsystem! The mysql container probably crashed halfway through initialisation in an earlier run. You should delete the mysql data and quickstart again. See the provided solution here: Quickstart failed on fresh mac

It looks like you are using WSL (Windows Subsystem for Linux). You must install Docker Desktop to use Docker containers within the WSL.

You will have other issues or configurations that might cause automated installation processes to fail.

Another option is to try using VirtualBox to run Tutor on Windows. However, you might run into compatibility issues with Hypervisor. If so, then you can use only one virtualization tool (WSL or VirtualBox).

1 Like

@regis Did try again. And the error doesn’t happen again.
But there is another error. Think it doesn’t relate to memory issue.
My docker machine is set up with 5 GB memory.

 Error: Command failed with status 137: docker-compose -f /home/develop/.local/share/tutor/env/local/docker-compose.yml --project-name tutor_local exec lms sh -e -c dockerize -wait tcp://mysql:3306 -timeout 20s
    ./ lms --settings=tutor.production migrate

    ./ lms --settings=tutor.production create_oauth2_client \
        "" "" public \
        --client_id android --client_secret lWQtlkwmXtmt5cm8okxunrGT \

    # Fix incorrect uploaded file path
    if [ -d /openedx/data/uploads/ ]; then
      if [ -n "$(ls -A /openedx/data/uploads/)" ]; then
        echo "Migrating LMS uploaded files to shared directory"
        mv /openedx/data/uploads/* /openedx/media/
        rm -rf /openedx/data/uploads/

Actually, I’m using Docker Toolbox which worked well with Edx DevStack already.
Tried Docker Desktop before, but there are some annoying issues. Then I stop using it and move forward with DockerToolbox.

Unfortunately, I don’t have a Windows computer on hand, so it’s difficult for me to debug this further.

Thanks, Tony. Just install WSL 2 Tech Preview. It work very well.

1 Like