Error upgrading from v11.2.9 to v11.2.10

After downloading the binary of v11.2.10 i tried to upgrade with tutor local quickstart it gave the following error.

[17871] Error loading Python lib '/tmp/_MEIa1GHWz/': dlopen: /lib/x86_64-linux-gnu/ version GLIBC_2.29’ not found (required by /tmp/_MEIa1GHWz/`

Even checking tutor version gives this error. My OS is ubuntu 16.04 LTS

Right. This seems to be due to the fact that we upgraded the Tutor CI from Ubuntu 16.04 to 20.04 during the switch from Travis CI to Github Actions. I’ll revert to an older release of Ubuntu.

Hmmm it looks like Ubuntu 16.04 is not supported by Github Actions:

Do you have the possibility to install Tutor via pip install? If not I can provide instructions on how to build a Ubuntu 16.04-compatible binary by yourself. But Ubuntu 16.04 came out of support in April this year, so I don’t think it would make sense for us to support this LTS release anymore.

Yes I realized that. ANd I also tried to perform Ubuntu release upgrade than upgrade the tutor. But than looks like I lost config. And I was not able to login. Like while running the tutor local quickstart I didnt found my domains saved already I had to re-enter all details. And after doing that i was not able to login.

This problem is unrelated to the Ubuntu 16.04 compatibility. Most likely, you are running Tutor as a different user and are not using the same environment. You should check that the value of tutor config printroot is the same as before you upgraded.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.