Ecommerce Plugin Error on Login


I installed the plugins from the tutor’s source code

The services are installed correctly, however, ecommerce has a login problem.

I ran the ecommerce logs

local tutor logs --tail = 100 ecommerce -f

And this message appears in the logs:

ecommerce_1 | AuthFailed: Authentication failed: HTTPConnectionPool (host = ‘’, port = 80): Max retries exceeded with url: / oauth2 / access_token / (Caused by NewConnectionError (’<urllib3.connection.HTTPConnection object at 0x7fb19fd46 >: Failed to establish a new connection: [Errno -2] Name or service not known ',))
ecommerce_1 | 2020-02-07 17: 32: 43,705 ERROR 11 [django.request] /openedx/venv/local/lib/python2.7/site-packages/django/core/handlers/ - Internal Server Error: / complete / edx-oidc /

Apparently / oauth2 doesn’t respond

I tested POST / oauth2 / access_token and got no response either

Do I need any more configuration?

Are you running this on a server on a local computer?

I’m using on server without domain (only configured domain on hosts file)

Now i put on real domain and i give this

 AuthCanceled: Authentication process canceled
ecommerce_1         | 2020-02-10 18:34:15,368 ERROR 10 [django.request] /openedx/venv/local/lib/python2.7/site-packages/django/core/handlers/ - Internal Server Error: /complete/edx-oidc/


Did you manage to fix the error?

I have the same problem.


May I ask if the problem is solved?

I have the same problem.

Did you do this?

No, I set the configuration and the following problem occurred after logging in:


Anyone solved this issue? I am also facing the same.


I am also facing the same issue any update how to solve it??

Guys, there are like three different issues we are talking about here. Can you please post the command you are running or the actions that you are doing that trigger the error along with the stack trace from the logs?

@regis, are there any steps to follow when we move ecommerce and discovery to HTTPS ?
Already ran tutor local init

Getting: AuthTokenError: Token error: Invalid issuer

@naresh21 Please describe the actions that you do and that trigger this error: are you running a command? visiting a webpage? if yes, which one?

It seems that the issuer setting was incorrect in the ecommerce plugin since the v3.12.2 tutor release. Can you please check whether the latest release (v0.1.13) of the ecommerce plugin fixes this problem? This seems to be the same problem as Tutor Ecommerce: AuthTokenError Invalid issuer

Thanks @regis

Upgrading ecommerce plugin to v0.1.13 solved the issue !!