Default SMTP Configuration - Timeout


Set up a new production instance of tutor/openedx - all running fine, DNS configured and accessing with SSL enabled successfully etc. All looks good at first glance.

I am (at least for now) trying to use the default included SMTP server/service, so I’ve kept the default SMTP config/haven’t changed anything.

I have however set some of the default email values (e.g. DEFAULT_FROM_EMAIL) to in the config.yml, run tutor config save & restarted all services.

Tried to sign up/in to receive confirmation email, and also tried forgot password email, but I am not receiving any emails. I have tested this on signing up with an outlook and a gmail account.

Logs are below from the smtp service:

Not sure if I need to change anything with the SMTP server to make it work - I know I can use an external service (e.g. google’s SMTP server) but it would be easier to use the included SMTP server for now!



Have you tried to see if you have closed the port on the vps?
If the vps provider has ports 25 closed? since for example linode for a new client has it closed.

I think this might be it - digitalocean seem to be hit and miss about whether they allow it open.

Is it possible to configure a different port for the inbuilt SMTP server?


Well, it’s a matter of trying.

Not sure if I’m just being stupid here - I have set the port under SMTP_PORT in the config.yml to 587 after discussing it with digitalocean & ensuring that port has its iptables set etc.

Despite this, exim is starting on 8025 as it did in my original screenshot. Interestingly the config says it defaults to 25 (not 8025, which seems like it might be coming from’s default value?). Seems like the config isn’t setting the port correctly?

Might be that is a red herring and unrelated - but I cannot find anywhere in my entire installation where 8025 is set and yet it still seems to default to the port as specified in the logs. I have done a full root grep search for ‘8025’ in the entire system and the only place it’s still mentioned is that file.

Yet restarting the whole tutor setup (even the entire server itself) still defaults to smtp 8025 on reboot.

Very odd?

Worth mentioning that setting this variable didn’t seem to solve it regardless :frowning:

You cannot configure the port to which the Tutor SMTP server will connect. This port has nothing to do with Tutor, and depends entirely on the other server configuration. You should really check your firewall. DigitalOcean is my primary deployment target and I never had connection issues before.

SMTP_PORT is the port to which the Open edX app will connect when trying to reach the smtp server. The SMTP server that ships with Open edX by default listens to port 8025, hence this value. You are correct that the documentation is incorrect. Here is the fix – and thanks for the heads-up :slight_smile:


Thanks for your response - it is odd that changing the SMTP_PORT in my config and running ‘tutor config save’ does not seem to change this value (or at least, the console still reports that it is using 8025).

I will do some further looking at the firewall - currently using ufw and as far as I know 8025 is as open as it can be (as is 25, but apparently digital ocean don’t allow SMTP (at least on port 25) for new accounts, after a support ticket with them)


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.