Custom AWS git-code-commit MFE repo giving error while quickstart

Hi @regis/Team,

I am getting the below error when I try to add my custom MFE in tutor by providing the below config in the “config.yml” file. I am using AWS Git-codecommit repo and ran the quick start command. The MFE is in master branch.

Command :

tutor local quickstart

Error :

Step 11/35 : RUN git clone https://git-codecommit.xxx.xxxx.com/v1/repos/frontend-template-application  --branch open-release/maple.1 --depth 1 .
 ---> Running in cb9c74e765ce
Cloning into '.'...
fatal: could not read Username for 'https://git-codecommit.xxx.xxxxx': No such device or address
The command '/bin/sh -c git clone https://git-codecommit.xxx.xxxxx/v1/repos/frontend-template-application --branch open-release/maple.1 --depth 1 .' returned a non-zero code: 128
ERROR: Service 'mfe' failed to build : Build failed
Error: Command failed with status 1: docker-compose -f /home/ec2-user/.local/share/tutor/env/local/docker-compose.yml -f /home/ec2-user/.local/share/tutor/env/local/docker-compose.prod.yml --project-name tutor_local up --remove-orphans --build -d

Config.yml :

"MYMFE_MFE_APP": {
            "name": "mymfe",
            "repository": "https://git-codecommit.xxx.xxxxx/v1/repos/frontend-template-application",
            "port": 2001,
            "env": {
                "production": {
                    "MY_CUSTOM_MFE_SETTING": "prod value"
                },
                "development": {
                    "MY_CUSTOM_MFE_SETTING": "dev value"
                }
            }
        }

Please help if you too have faced such issues.

It seems the error with git, I think git is trying to use ssh while your url is https maye be if you add .git to the end of the url it would work, like:

            "repository": "https://git-codecommit.us-east-1.amazonaws.com/v1/repos/frontend-template-application.git",

Hi @ghassanmas,

I tried the same but still got the same error.

Is the repository private? Do you need to add configuration to the container to give the user access to the repository?

Hi @BbrSofiane,

Yes, this is a private repo and I am just checking if we can modify the code and contents of frontend-template-application which I have cloned in my repo. Please let me know if there are any steps to add configuration. Also I can see in the error tutor is taking code from that the --branch open-release/maple.1. Is there anyway we can make tutor use ‘master’ branch instead of ‘open-release/maple.1’ branch because I am committing my code to default ‘master’ branch.

Thanks.

You can set the “version” parameter in your configuration of the MFE.

"MYMFE_MFE_APP": {
            "name": "mymfe",
            "repository": "https://git-codecommit.us-east-1.amazonaws.com/v1/repos/frontend-template-application",
            "port": 2001,
            "version": "master",

I am not familiar with git codecommit so I can really help there. My assumption is that you have to make sure the repo is accessible from within the container.

Hi @BbrSofiane,

Will try this config and let you know if I get any issues.

Thank you

1 Like