Could not find a version that satisfies the requirement

I am getting the following error while running the command pip install tutor-openedx

-Could not find a version that satisfies the requirement tutor-openedx (from versions: )
No matching distribution found for tutor-openedx

I have Ubuntu 18.10

what does “pip --version” print?

pip 9.0.1 (python 2.7)

Also while trying to install it on Mac I get the following error.

You will need python >= 3.6

You can add pip3 to the first command so it becomes:

sudo apt install python3 libyaml-dev python3-pip

and then use

pip3 install tutor-openedx
1 Like

That worked. Thanks a lot!
Also, could you guide me on what the error on nginx is in my latest screenshot.

The screenshot shows port 80 is already in use, maybe you are running other service in that pc?
What command did you issue to get that error?


As noticed by @juansele 80 port seems to be already in use… If you want to keep it, you need to run Open edX behind a web proxy. See the documentation here

Hope that helps!

I ran tutor local quickstart.

On running this command
sudo ln -s “$(tutor config printroot)/env/local/proxy/nginx/openedx.conf” /etc/nginx/sites-enabled/
I get the following error
ln: /etc/nginx/sites-enabled/: No such file or directory