'connection refused' - discovery plugin

Having the same problem as Getting 'Connection refused' error after running tutor local quickstart · Issue #13 · overhangio/tutor-discovery · GitHub

Logged in to the discovery container, and tried:

curl -v https://domain-redacted.com

Result is:

connect to port 443 failed: Connection refused

So it seems to be impossible to connect to my LMS_HOST from inside the container.

Using flag --no-tcp-nodelay doesn’t make a difference, there seems definitely to be a routing problem.

Why is your “domain-redacted.com” domain name resolving to from within your container?

That’s what I don’t understand… external domains resolve without any problem. Investigating further, I think it has something to do with loopback NAT, but still couldn’t solve, some very confusing posts about loopback/hairpin NAT on Google.

Something very strange… I have another docker container running on the same machine (Odoo, also python based). And curl to my own domain from within that container works without any problem !!! So maybe some docker startup parameter that’s missing or wrong, I will try to find it out further in the course of this week.

Update: the tutor docker containers have in /etc/resolv.conf :

options edns0 trust-ad ndots:0

while the other (working) container has simply the two Google DNS servers :


Tomorrow figure out where that server comes from, and that strange options rule … problem is there, isn’t resolving correctly.

Got it working. Complete disaster my network config, also a mixup of legacy Ubuntu docker.io and docker-ce libs :face_with_head_bandage:
Purged completely my docker installation (including /var/lib/docker), and starting over…

1 Like