Overhang.io

CMS_HOST cannot take effect

HI
I use tutor to set up LMS_HOST=10.0.1.205,CMS_HOST=10.0.1.205:18000,I used 10.0.1.205:18000 to log in, but could not enter the studio page

Hello,

Isn’t CMS default port 18010 ? Give it maybe a try ?

Hi @jonas2463! Setting up an ip address with a port will simply not work :slight_smile: are you trying to access the studio on your laptop? If yes, you should setup a fake domain name and access the studio at http://studio.localhost.

Hi @regis I want to set up one that can be accessed on the same LAN,so I use IP instead of domain name,
Can you tell me how to set it?

Basically, you will need to create and configure a web proxy yourself if you want to assign an arbitrary port to the cms: https://docs.tutor.overhang.io/local.html#recipes

Hi @regis I setup a fake domain name and access the studio at http://studio.localhost ,but cann’t enter the cms page

Hi @regis! I had the same issue. Can’t access the studio from http://studio.localhost . I installed openedx with Tutor under ubuntu desktop 16.04. LTS and did access LMS from http://localhost. I also powered up a new instance using fake domain name but still can’t access studio. I didn’t make any change the default ports numbers.
Any suggestions please?

@jonas2463 @SayHi When you say “can’t access studio/cms”, what does that mean? Do you get an error page (if yes, which error?), a 404 error, a 500 error?

Hi @regis, the error is “We can’t connect to the server at www.studio.localhost.”. I also tried with the fake address I entered when first installed edx using “tutor local quickstart” and which is set in the file “config.yml” , “CMS_HOST: studio.myopenedx” and had the same error of connection. I tried studio.localhost:18010 with no success, I checked the files “cms.auth.json” and “cms.env.json” for specific port number but have not found.
n.b: I am using a partition of ubuntu 16.04.LTS not a virtualbox gest os.

@SayHi did you try http://studio.localhost ?

@regis, Yes I did, and for many times with no success. When typing http:://studio.localhost it keeps searching for a while and finishes by returning that error “We can’t connect to the server at www.studio.localhost.”, noting that firefox changes the “http://” by “www” in the above error.

I apologize for this elementary questions @regis but I am stuck with this error for 3 weeks. After many attempts of reinstalling openedx by tutor on Ubuntu server then ubuntu desktop all on Virtualbox and finally making an independent ubuntu desktop partition.

I hope to move on as many questions related to production-like situation are still unanswered for me.

@SayHi Let’s check the basics:

  1. What command are you running?
  2. What Tutor version are you running? (tutor --version)
  3. Are there any error logs? (tutor local logs --tail=200)
  4. Does studio.localhost resolve to the right host? (dig studio.localhost)

Hi @regis, I really appreciate your help despite of your busy schedule and heavy tasks.
I intend to propose OpenEdx to my university in Adrar/Algeria and need to have a clear idea of all deployment aspects and requirements.

As for the first question: what command Am running?
I guess you mean the command of running OpenEdx. Well since Docker is configured to start with Ubuntu (16.04.LTS), I just open the browser and type “http://localhost” to get the LMS.


But when typing “http://studio.localhost” I get server not found error.

  1. The screen below shows the versions of Docker, Docker-compose and Tutor. Also the docker images installed.

  2. The error file logs is huge and can’t be displayed in one page. Please let me know if you want it sent to a particular Email.

  3. The result of the command “dig studio.localhost” is shown bellow:

N.b: please feel free to request any other information.
Best regards

I meant: what terminal command are you running? I assume it is tutor local quickstart?

You may post it to https://pastebin.com/.

It seems that on your OS, studio.localhost does not resolve to 127.0.0.1, for some reason. I suggest you manually add studio.localhost to the /etc/hosts file by replacing 127.0.0.1 localhost with 127.0.0.1 localhost studio.localhost in /etc/hosts. Then, run dig studio.localhost again (post the result) here and try again accessing http://studio.localhost in your browser.

Hi @regis :slight_smile: It works.

and here is the result of “dig studio.localhost”

I just replaced “127.0.0.1 localhost” by “127.0.01 localhost studio.localhost” in /etc/hosts file.
In a production scenario do I have to do it manually as well ?

I hope this will help other folks having the same issue.

Thank you.

Edit: the file logs is posted here : https://pastebin.com/MfH8nAwx

:+1:!

No, this is only required for accessing your platform from localhost, so just for local testing.