"Certificates" submenu missing in Django admin

Hi

I enabled certificates using the steps described here

https://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/configuration/enable_certificates.html#enable-course-certificates-in-studio-and-the-lms

  1. In the lms.env.json and cms.env.json files, set the value of CERTIFICATES_HTML_VIEW within the FEATURES object to true .

“FEATURES”: { … ‘CERTIFICATES_HTML_VIEW’: true, … }

  1. Save the lms.env.json and cms.env.json files.
  2. If it does not exist already, create the folder /tmp/certificates owned by the user and group www-data . Depending on your configuration, this folder might not survive reboots, and so might need to be created by a script.
  3. Run database migrations.

After reboot, I dont see “the certificates” menu, which is supposed to be in studio.myhost.com/admin

[4.9.4. Configure Course Certificates for Your Open edX Instance]

Under Site Administration > Certificates , add an HTML View Configuration, and select Enabled .

Any help would be appreciated
Thanks

Hi @nachham! There is no need to do the steps described in the link you posted. Certificates are enabled by default in Tutor. However, the “certificates” menu is not present in /admin but in the Course settings menu in the studio. For instance, go to: https://studio.demo.openedx.overhang.io/course/course-v1:edX+DemoX+Demo_Course (login: admin@overhang.io password: admin). In the “Settings” menu, there is a “Certificates” entry.
If you really want to access the django admin menu, then you should access it from the LMS (myhost.com/admin and not studio.myhost.com/admin).

Merci @regis. Sorry! I should have been more explicit describing the certificates’ generation issue. Let’us illustrate the unfortune case with https://demo.openedx.overhang.io/

According to this tutorial https://www.youtube.com/watch?v=IJvMjou8e64

  1. I changed the “demo” course mode to “honor” in https://studio.demo.openedx.overhang.io/admin/
  2. I created a simple grade (in gradings) with 100 points
  3. I created a simple question in the demo course (true-false) with 100 points
  4. In studio Settings > certificates, I setup a new certificate. (signatory name and title)
  5. When I click on “Preview certificates” the following error occurs

I cannot go any further as with the tutorial above!
There are two things that caught my intention:

First: there suppose to be a “certificates” submenu under Instructor

Second, according to Section 4.9.4 in https://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/configuration/enable_certificates.html#id15

There should be a Site Administration > Certificates submenu which I don’t see in
https://studio.demo.openedx.overhang.io/admin/

I know that under Advances settings > Certificate Web/HTML View Overrides one can override some of the certificates parameters as with the example below, but that does not help**

{
“document_title”: “CERTIFICATE”,
“certificate_logo_large”: " https://via.placeholder.com/350x150 " ,
“certificate_description”: “ispto facto”,
“accomplishment_copy_course_description”: “ispto facto”,
“accomplishment_copy_description_full”: “ispto facto”,
“course_number”: " ",
“course_number_separator”: " ",
“logo_src”: " https://via.placeholder.com/100x50 ",
“logo_url”: " https://demo.openedx.overhang.io "
}

You always get…

There is a problem with this certificate.
To resolve the problem, your partner manager should verify that the following information is correct.
The institution’s logo.
The institution that is linked to the course.
The course information in the Course Administration tool.
If all of the information is correct and the problem persists, contact technical support

Merci!

That’s a classic :slight_smile: It’s funny, I just helped a client resolve this very issue. You need to add an enabled “Certificate html view configuration” in the LMS admin: https://demo.openedx.overhang.io/admin/certificates/certificatehtmlviewconfiguration/

It makes total sense, I really wonder why so many users face this issue :stuck_out_tongue:

(just kidding, there’s zero chance that new Open edX users can resolve this on their own. Actually, it would be great if someone wrote a comprehensive HOWTO on this.)

Hilarious! As simple as that!
Merci Régis!