Can't access CMS with Tutor on local machine

Hi everyone,
I’m new with Tutor and I’d like to deploy an OpenEDX-based plateform.
I run it on a Linux laptop (Ubuntu 20.04 LTS) and put these in the quickstart config :

LMS HOST : (My local ipv4)

I can access the LMS host but not the CMS, neither with my server (on which tutor is running) or with any other computer connected to my local network. I tried several different ports (8888, 5000, etc.); and I never got access to the CMS. The only time I succeeded was when I changed to config to put the cms adress to, but couldn’t access to the LMS.

I don’t want to just deploy it on dev mode because I want to be able to access the website from other computers located on my local network, since I don’t work on the server. I opened all the ports I tried (8888, 50000, 8000, etc.) on my linux machine with the command sudo ufw allow {PORT}/tcp. It seems that all these ports are opened, but I still can’t access to the cms if it is set to a port.
I also tried to set the CMS adress to but it didn’t work either.

What am I doing wrong ?

I assume you are running in production mode since you’ve your own LMS and CMS host names, in that you have to use DNS names. I don’t think you can use IP addresses.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.