Cannot access CMS from browser

Hello. I am an absolute beginner with tutor (12.0.1) and I am having trouble accessing the CMS from my browser. I would greatly appreciate any help I can get.

I have set up tutor on debian 10 with tutor local quickstart, and provided a domain name and a subdomain for the LMS and CMS respectively. My /etc/hosts includes the lines

The LMS seems to be working fine, but when I try to access the CMS through my browser (from an external computer), I get “We can’t connect to the server at”

I tried accessing the CMS with a command-line browser on the server (i.e. w3m, but in that case the browser says

SSL error: error:14094438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error

I should also mention that I have this problem in production mode. When not in production, I can access the CMS locally with w3m.

I have been carrying out several tests for a few days, but none of them have worked.

Thank you in advance for any suggestions.

I just realised that was not responding to ping from an external computer, so I added it to the external computer’s /etc/hosts, and now I get the SSL error on my browser from an external computer:

Secure Connection Failed

An error occurred during a connection to Peer reports it experienced an internal error.


Hi @marcmelendez! You most probably enabled HTTPS during quickstart. This is not going to work if you did not setup the right DNS records: Install Tutor — Tutor documentation
You should disable https during quickstart. Note that manually defining hosts in /etc/hosts will almost certainly not work in all cases, for instance when you’ll want to enable extra services such as Discovery and Ecommerce.

Thank you very much for the quick reply, @regis!

I deactivated HTTPS during quickstart and I can access both LMS and CMS from the server command-line with w3m, but not on the browser from an external computer.

Here is the situation: my server has a domain name (let’s call it I own a domain name (say, I have defined two subdomains:

and have pointed them at I don’t understand how I am supposed to do this to make tutor’s LMS and CMS work over HTTPS. Do you have any suggestions on where I can find a tutorial?

Thanks again for the help.

Thank you for your helpful comments, @regis . I have tutor working provisionally.

I have not been able to work out how to configure my coolname subdomains yet, but I have discovered that my VPS provides an extra uglyname domain. I have set up tutor with LMS on uglyname732 and CMS on uglyname733, and everything seems to be working fine.

I would be grateful if anyone could direct me to a tutorial that helps me set up the coolname subdomains.

Thanks again for all the help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.