Caddy where are you?

I updated a test instance this morning to find no caddy and the system not working then tried to build a fresh instance again no caddy installed but the test worked.

is 11.1.1 removing caddy or is there just a config file out of synch?


Caddy is very much still supposed to be there :slight_smile: I’m going to need more information than that in order to debug this.

What do you mean by “updated”? Did you update the OS or Tutor? From which version? What do you mean by “no caddy”? Is the caddy container not running? What is the output of tutor config printvalue RUN_CADDY?

I have no idea what this sentence means. Did you build a fresh server instance? Or a Docker image? What was the test? What did it mean that it “worked”?

As a rule of thumb, on the forums you should not expect answers to contain more words/characters than your question. So if you want useful answers you should write detailed questions.

No problem regis thanks for the reply

I started by doing an update to the system following the instructions i.e. run quickstart again. I added an Xblock (Xpdf) and rebuild the open edx image. At that point a strange thing happened the Caddy container was no longer listed but an openedx_assets was showing up as a container. Checked with portainer for all the containers and found that the Caddy container was now orfened.

Having checked the config file for the line run_caddy=False and not finding It I build a new machine and installed the 11.1.1 version of tutor. Again no caddy instance but the Ngnix servers were now running the lets encrypt protocal and the system was running.

I then build another test machine and installed 11.1.0 and caddy then was installed.

All of these were on unbuntu 18 lts and with all prerequisties installed. pip libyaml python2 docker etc.

The difference I can see between the version was that the 11.1.1 did not call caddy to install in the process and 11.1.0 did.

I hope that helps describe my experience.