Bad Request (400): Unable to connect from browser

Hi,
I was trying to deploy the openEDX locally using
tutor local quickstart
I am able to up all the containers but in the configuration how do I change the lms and cms host to ip_address:port, as I am going to use openEDX service in a private network.
Although I am able to curl from the host machine. But while using a browser from diff machine I am not able to open the service getting Error: Bad Request (400)
I tried changing the below

  1. updating lms_host and cms_host config.yml file
  2. update production.py with my localhost IP to allow_host variable for both lms and cms
  3. also tried with passing the new nginx.conf file to nginx-container and try to provide separate server port to lms and cms.

But getting the same error. Can someone help me out how to handle the configuration?
Thanks in advance.

Hi @apoorvvarma !
Try to configure your /etc/hosts file as you see on my screenshot, for production mods. After that you should see both LMS and CMS on your browser.

If you using test mods, just choose " n " after

$ tutor local quickstart

This configurations for localhost and testing. But if you want to use your local machine as a web server ?
That’s an other issue. You may need to configure your DNS, IP and router, I guess. If you using Cloud provider you must configure DNS record, domain and subdomain. Thanks…

God luck!

Thanks @qali :slightly_smiling_face:
I will try changing the /etc/hosts file settings and check with the network team for dns entries.