Tutor local quickstart failed: "Connection timed out"

I have installed docker, docker compose PIP3, python 3 and tutor, and they are the latest versions. Then when I run tutor local quick start, this error will appear. I run it in a virtual machine and the system is Ubuntu 20.0.4. I have tried it countless times

Please look at the top “get: 165”. This should not be the reason for the timeout. Every time I run here, I will report an error. Some people in the community have the same situation as me. I hope someone can help me

I’m currently installing Tutor on a VM to try match your setup on Ubuntu, will let you know how it goes.

Hi @julien
I’ve managed to install Tutor on Ubuntu 20.0.4 without issue, I’m unable to replicate your problem which leads me to believe it’s most likely connectivity related (this does not automatically mean YOUR internet is bad, just that something in the route is bad)
I figured out though that the Debian sources are most likely coming from one of Tutor’s containers, rather than the base OS.

This might function as a workaround, try force it to use a specific IP address for {deb|security}.debian.org by creating a hosts entry on your server

sudo nano /etc/hosts

create a new line with an alternate IP address and deb.debian.org and security.debian.org localhost tutortestvm	deb.debian.org security.debian.org

Here are some alternative IP’s you could possibly try: (UK) (USA) (USA alt) (USA alt) (Taiwan) (Australia)

Some testing I’ve done indicate that it should work for the docker containers to resolve the new IP address instead of the “geographically closer” one that deb.debian.org typically resolves to. If there is another mirror that you prefer to use then put that mirror’s IP address (eg mirrors.tuna.tsinghua.edu.cn which you were using here is

Thank you, Joel. Can you successfully start tutor local quickstart after installing tutor

correct, no issues starting services or accessing the web page on my side. tried in the default config and with the modified hosts file I suggested above and both worked on Ubuntu 20.0.4


Joel, this is my host file. Am I right to modify it like this

Don’t worry about sources.list file. I was giving you bad information yesterday. Sorry

Just do edit on /etc/hosts file and add a new line for the IP address to resolve to:
xxx.xxx.xxx.xxx deb.debian.org security.debian.org

replace xx.xx.xx.xx with the IP address of another mirror
eg: deb.debian.org security.debian.org
or deb.debian.org security.debian.org
for example

So when tutor tried to fetch files from deb.debian.org it will use the mirror who’s IP address is in hosts file. then try again to run the installation/quickstart

yup, that looks good, save file and try install again
hopefully this works :slight_smile:

It’s been revised, but it looks almost the same as before, because I’ve repeated it countless times, alas

Joel, I have a new problem here

ERROR [profile 3/3] RUN bash -c "set -a && source /openedx/env/prod 147.2s

[profile 3/3] RUN bash -c “set -a && source /openedx/env/production && source /openedx/env/production.override && npm run build”:
#0 1.549
#0 1.549 > @edx/frontend-app-profile@1.0.0-semantically-released build /openedx/app
#0 1.549 > fedx-scripts webpack
#0 1.549
#0 1.675 Running with resolved config:
#0 1.675 /openedx/app/node_modules/@edx/frontend-build/config/webpack.prod.config.js
#0 1.675
#0 145.8 Error parsing bundle asset “/openedx/app/dist/330.3a3d76a6908b7f608738.js”: no such file
#0 145.8 Error parsing bundle asset “/openedx/app/dist/app.2f636ffa8f70348cb797.js”: no such file
#0 145.8 Error parsing bundle asset “/openedx/app/dist/runtime.ea498ce4af2bf5348ae9.js”: no such file
#0 145.8
#0 145.8 No bundles were parsed. Analyzer will show only original module sizes from stats file.
#0 145.8
#0 145.9 Webpack Bundle Analyzer saved report to /openedx/app/dist/report.html
#0 146.5 assets by status 1.1 MiB [cached] 7 assets
#0 146.5 Entrypoint app = runtime.ea498ce4af2bf5348ae9.js 330.3a3d76a6908b7f608738.js app.2f636ffa8f70348cb797.js 5 auxiliary assets
#0 146.5 orphan modules 1.89 MiB [orphan] 779 modules
#0 146.5 runtime modules 3.55 KiB 8 modules
#0 146.5 cacheable modules 2.66 MiB 565 modules
#0 146.5
#0 146.5 WARNING in ./node_modules/react-responsive/dist/react-responsive.js
#0 146.5 Module Warning (from ./node_modules/source-map-loader/index.js):
#0 146.5 (Emitted value instead of an instance of Error) Cannot find source file ‘webpack:///dist/react-responsive.js’: Error: Can’t resolve ‘./webpack:///dist/react-responsive.js’ in ‘/openedx/app/node_modules/react-responsive/dist’
#0 146.5 @ ./node_modules/@edx/frontend-component-header/dist/Header.js 2:0-42 75:97-107 77:94-104
#0 146.5 @ ./node_modules/@edx/frontend-component-header/dist/index.js 1:0-30 5:15-21
#0 146.5 @ ./src/index.jsx
#0 146.5
#0 146.5 1 warning has detailed information that is not shown.
#0 146.5 Use ‘stats.errorDetails: true’ resp. ‘–stats-error-details’ to show it.
#0 146.5
#0 146.5 ERROR in ./src/index.scss
#0 146.5 Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
#0 146.5 ModuleBuildError: Module build failed (from ./node_modules/image-webpack-loader/index.js):
#0 146.5 Error: Cannot find module ‘mozjpeg’
#0 146.5 Require stack:
#0 146.5 - /openedx/app/node_modules/imagemin-mozjpeg/index.js
#0 146.5 - /openedx/app/node_modules/image-webpack-loader/index.js
#0 146.5 - /openedx/app/node_modules/loader-runner/lib/loadLoader.js
#0 146.5 - /openedx/app/node_modules/loader-runner/lib/LoaderRunner.js
#0 146.5 - /openedx/app/node_modules/webpack/lib/NormalModuleFactory.js
#0 146.5 - /openedx/app/node_modules/webpack/lib/Compiler.js
#0 146.5 - /openedx/app/node_modules/webpack/lib/webpack.js
#0 146.5 - /openedx/app/node_modules/webpack/lib/index.js
#0 146.5 - /openedx/app/node_modules/webpack-cli/lib/webpack-cli.js
#0 146.5 - /openedx/app/node_modules/webpack-cli/lib/bootstrap.js
#0 146.5 - /openedx/app/node_modules/webpack-cli/bin/cli.js
#0 146.5 - /openedx/app/node_modules/webpack/bin/webpack.js
#0 146.5 - /openedx/app/node_modules/@edx/frontend-build/bin/fedx-scripts.js
#0 146.5 at Function.Module._resolveFilename (internal/modules/cjs/loader.js:815:15)
#0 146.5 at Function.Module._load (internal/modules/cjs/loader.js:667:27)
#0 146.5 at Module.require (internal/modules/cjs/loader.js:887:19)
#0 146.5 at require (internal/modules/cjs/helpers.js:74:18)
#0 146.5 at Object. (/openedx/app/node_modules/imagemin-mozjpeg/index.js:4:17)
#0 146.5 at Module._compile (internal/modules/cjs/loader.js:999:30)
#0 146.5 at Object.Module._extensions…js (internal/modules/cjs/loader.js:1027:10)
#0 146.5 at Module.load (internal/modules/cjs/loader.js:863:32)
#0 146.5 at Function.Module._load (internal/modules/cjs/loader.js:708:14)
#0 146.5 at Module.require (internal/modules/cjs/loader.js:887:19)
#0 146.5 at processResult (/openedx/app/node_modules/webpack/lib/NormalModule.js:713:19)
#0 146.5 at /openedx/app/node_modules/webpack/lib/NormalModule.js:819:5
#0 146.5 at /openedx/app/node_modules/loader-runner/lib/LoaderRunner.js:399:11
#0 146.5 at /openedx/app/node_modules/loader-runner/lib/LoaderRunner.js:251:18
#0 146.5 at runSyncOrAsync (/openedx/app/node_modules/loader-runner/lib/LoaderRunner.js:156:3)
#0 146.5 at iterateNormalLoaders (/openedx/app/node_modules/loader-runner/lib/LoaderRunner.js:250:2)
#0 146.5 at /openedx/app/node_modules/loader-runner/lib/LoaderRunner.js:223:4
#0 146.5 at processTicksAndRejections (internal/process/task_queues.js:84:21)
#0 146.5 @ ./src/index.jsx 13:0-22
#0 146.5
#0 146.5 1 ERROR in child compilations (Use ‘stats.children: true’ resp. ‘–stats-children’ for more details)
#0 146.5 webpack 5.50.0 compiled with 2 errors and 1 warning in 137379 ms
#0 146.8 npm ERR! code ELIFECYCLE
#0 146.8 npm ERR! errno 1
#0 146.8 npm ERR! @edx/frontend-app-profile@1.0.0-semantically-released build: fedx-scripts webpack
#0 146.8 npm ERR! Exit status 1
#0 146.8 npm ERR!
#0 146.8 npm ERR! Failed at the @edx/frontend-app-profile@1.0.0-semantically-released build script.
#0 146.8 npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
#0 146.9
#0 146.9 npm ERR! A complete log of this run can be found in:
#0 146.9 npm ERR! /root/.npm/_logs/2022-05-17T13_30_30_551Z-debug.log

failed to solve: executor failed running [/bin/sh -c bash -c “set -a && source /openedx/env/production && source /openedx/env/production.override && npm run build”]: exit code: 1
Error: Command failed with status 17: docker-compose -f /home/julien/.local/share/tutor/env/local/docker-compose.yml -f /home/julien/.local/share/tutor/env/local/docker-compose.prod.yml -f /home/julien/.local/share/tutor/env/local/docker-compose.tmp.yml --project-name tutor_local up --remove-orphans --build -d

Is there anything useful in this log?

I don’t know why I can’t find this file

There is nothing in the open file. It should be that the file is not found

Hi, Joel, I found this file, but I can’t analyze any useful information. Can you help me

can you upload the actual file somewhere or paste the contents into a Preformatted Text block, screenshots of logs are generally not that helpful. Thanks

Hi Joel, can you tell me how you installed docker compose? And its version number

Docker = 20.10.16
Docker-compose = 1.25.0