Tutor just randomly shuts down after a day

Dear all,

I am having a very strange problem. I am running Tutor on a dedicated VPS with 10 GB of ram and 4 CPU cores. The software works perfectly fine, is fast, and takes about 20% of the CPU when running. However, the only think that is troubling me is the fact that it just randomly stops working after approx. a day. So, if I start the server at 8 AM, it will work perfectly fine till the next day 8AM. When I approach my domain name where it was working fine, I get a ERR_CONNECTION_TIMED_OUT. When I look at the Dockers, everything is still running.

I have tried to look around in the error logs and I do not see any critical errors. When I run tutor local quickstart to restart everything, the Tutor instance will still not be reachable by my domain name.

The only thing that fixes this is a complete server restart.

Do you guys have any idea what might be going wrong here?



Hmmm this is intriguing. Can you check whether your 80/443 ports are still up, both from inside the VM and outside? What is your OS and who is your hosting provider?

It is very strange!
Now as I check, the ports are indeed closed for some very strange reason. I’m not sure why. I’ve used several external websites to check port 80 and 443. Both apparentely closed.

For the VM: nmap localhost shows that port 80 and 443 should both be open. The provider is TransIP in The Netherlands. The OS is Ubuntu 20.04

I have no idea how to investigate this further :-/ This looks like an issue with your provider, but I’ll keep an eye open in case someone else reports a similar problem. Please comment here if you find something.

Yeah… I’m out of options too. Could I maybe supply some logs you suspect might contain information about this issue? I only generally looked over tutor local logs and grepped for “error”…