Running tutor local with local development repository

Hi

We are customizing the edx platform. As suggested we have gone through the dev setting and running it. How to run the same using “tutor local start” with our own path of edx-platform. kindly suggest.

As per my knowledge “tutor local start” will run the open edx platform in production configuration.

Hi @vsvvssrao,

This information is available in the Tutor documentation. I suggest you read through it all, as it contains a lot of information that I think you will find useful:

https://docs.tutor.overhang.io/configuration.html#custom-open-edx-docker-image

hi @ak00001,

we are doing the following.

  1. running the tutor with custom path lets say
    tutor dev runserver -v /home/vs/Documents/lms/openedx/edx-platform:/openedx/edx-platform lms

  2. we are doing some cutomization in the lms codebase in the following path while running the dev

  3. So if we build it and start will my change reflect?

Kinldy help as the above process what we are doing is not working as expected.

Appriciate your help in this regards in advance.

Sorry, but I can’t provide you any meaningful information on this issue as I haven’t tried it.

1 Like

If I understand correctly, what you are trying to achieve @vsvvssrao is to run a customized version of edx-platform in production. Am I correct?

In that case, what you need to do is to push your changes to a remote repository and build a custom Docker image. The exact instructions are here: https://docs.tutor.overhang.io/configuration.html#running-a-fork-of-edx-platform

1 Like

Yes you are correct.

@regis,

I tried building using Running a fork of edx-platform but right now the error I am facing in my production server is that .manage.py file access is not there.

Any help regarding this.

Regards,
VS

I don’t quite understand. Can you clarify? At a minimum, we need the command that you run and the error stacktrace.