Migration Issue

I need your assistance for the below issue i’m facing.

I followed all the steps mentioned in the Tutor to configure Tutor with OpenEDX. I also followed OpenEDX deployment steps. But when I ran “tutor local quickstart” command. OpenEDX models started migrating but it stopped after sometime as it started giving some errors. I tried few time but each time the errors were different.
First attempt:

Applying some_table.0001_initial...Error: Command failed with status 137

echo "Loading settings $DJANGO_SETTINGS_MODULE"

Second attempt:

 django.db.utils.OperationalError: (1050, "Table 'some_table' already exists") 

As I said, I tried reconfiguring tutor OpenEDX deployment for few times, each time the Table name was different with the same error as above.

Hi @sharath02! Unfortunately this is a frequent issue, as you may have discovered by searching this forum. The reason for this error and how to solve it is described in the docs: https://github.com/overhangio/tutor/blob/master/docs/troubleshooting.rst#running-migrations-killed--command-failed-with-status-137-docker-compose

This information is not yet reflected in https://docs.tutor.overhang.io because we have not yet made a new version, but this should happen pretty soon.

As in solution it mentioned that we have to allocate 4-5GB to the Docker daemon. I even tried it but still it was throwing errors.

@sharath02 did you follow the other instructions? (i.e: deleting the mysql data?)

@regis yes I did. I did all possible things to make it work but hard luck.

This is quite strange. Please run the following exact commands and paste the result (including the commands) here:

tutor local stop
docker ps