Issue with TUTOR_ROOT on MacOS

In MacOS, when there is not a an explicit TUTOR_ROOT defined with an environment variable.

Any command with tutor says:

Error: Project root does not exist. Make sure to generate the initial configuration with `tutor config save --interactive` or `tutor local quickstart` prior to running other commands.

After doing:

tutor config save
Configuration saved to /Users/neithan/Library/Application Support/tutor/config.yml
Environment generated in /Users/neithan/Library/Application Support/tutor/env

Then, performing a:

 tutor local quickstart

generates errors like:

ERROR: for mysql  Cannot start service mysql: Mounts denied: approving /Users/neithan/Library/Application Support/tutor/data/mysql: file does not exist

ERROR: for mongodb  Cannot start service mongodb: Mounts denied: approving /Users/neithan/Library/Application Support/tutor/data/mongodb: file does not exist

ERROR: for elasticsearch  Cannot start service elasticsearch: Mounts denied: approving /Users/mendezr/Library/Application Support/tutor/data/elasticsearch: file does not exist

ERROR: for caddy  Cannot start service caddy: Mounts denied: approving /Users/neithan/Library/Application Support/tutor/env/apps/caddy/Caddyfile: file does not exist

ERROR: for redis  Cannot start service redis: Mounts denied: approving /Users/neithan/Library/Application Support/tutor/env/redis/redis.conf: file does not exist

I believe the error is produced by the blanks in the folder name, specifically “Application support”.

As a workaround we do this in MacOS, before doing anything else:

export TUTOR_ROOT=$HOME/.local/share/tutor

Could we this be solved also in tutor by default so we have a consistent experience among *nixes? (so we have in MacOS the same sane experience than in GNU/Linux.)

Isn’t this the same issue as: ?

EDIT: to clarify, the Error: Project root does not exist error is normal. It means that you have not yet created a project, and you should run tutor config save --interactive or tutor local quickstart.

I took a look to the docker for mac issue.
However, in both cases that I described (the one that failed and the workaround) are mounted in /Users/

On the other hand, I don´t know if “Application Support” has any security restriction on MacOS, I supossed it was because of the blank space in the folder name.

The only unexpected issue I see in your initial post are the “Mounts denied: approving…” messages.
People have been able to run tutor local quickstart on Mac OS for a long time, and there have always spaces in the home directory. I encourage you to try out the solution mentioned in the Github issue above.

Disabling experimental feature “gRPC Fuse” fixes this!

You are nailing it, @regis! Cheers!

Since I will probably come back the next year with new discoveries, I take the moment now to wish you happy holidays.

Marking this as solved.