Discovery API no courses

Hi,
I have a small problem with discovery api.
I can run the indexing with

But when i go this request https://discovery.v2.xxx/api/v1/course_runs/ i don’t get any result

But in the admin i have a the list of courses

How to fix ?

Hi @jefcolbi,
Can you please check that your course runs are not hidden? The “hidden” checkbox should be unchecked in e.g: https://discovery.v2.xxx/admin/course_metadata/courserun/1/change/

As you can see it is not

I managed to reproduce the issue and I’m currently investigating this.

Good.
I am waiting for the answer thanks.

@jefcolbi I fail to reproduce the issue anymore. I cannot debug this further, as I have made yet unreleased changes to tutor and the discovery plugin. Thus, it’s difficult for me to reproduce the exact circumstances of your own bug. Also, there are other things I need to be focussing on right now.

Sorry about that :-/ I suggest you attempt to run quickstart again; if that does not solve the problem, then you should keep an eye on coming tutor and plugin releases. If you really must debug this right away, I suggest you subscribe to an LTS license: https://overhang.io/tutor/lts

Hi, I got the same problem with discovery
HTTP 200 OK
Allow: GET, POST, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
“count”: 0,
“next”: null,
“previous”: null,
“results”: []
}
but search list is ok


I think the bigger problem with this is creating a program in discovery admin site but lms and ecommerce only return 404 error because they can’t retrieve any data from discovery api.
There is no error from logs as well.

It’s been quite long since this issue arose @jefcolbi … Were you able to resolve ? If yes, please share the solution or work around.

@regis I tried on all latest versions:

tutor version 3.12.3
ecommerce plugin version 0.1.13
discovery plugin version 0.1.17

Issue is same as described by @jefcolbi:

tutor local exec discovery ./manage.py update_index --disable-change-limit

Above command shows courses are indexed but at the time of fetching through API, result is empty

/api/v1/courses/

{
“count”: 0,
“next”: null,
“previous”: null,
“results”: []
}

If you are able to debug this, I’m interested in the solution. Since I cannot reproduce it, I cannot provide further guidance.

@regis what version of tutor and plugins are you running?

Locally I have it working fine, but not in production, even with the same versions :confused: