Content translations, but the changes won't apply

For example, I’m trying to translate this label, I’ve mentioned it in djangojs.po

as you can see I wrote the translation and as I think I did the right path for this locale folder.

I was following this instruction

and was running these commands:

tutor images build openedx openedx-dev

tutor local stop && tutor local start -d

but it didn’t change, I’ve cleared the cache of the browser. I’ve tried to move this translation to django.po and back to djangojs.po, no results.

This topic not about only this label, many sentences are not translating.

If anyone has an idea of what I’m doing wrong, please tell me.

I observed a similar issue with a customer recently. We observed that the issue was resolved if we removed all contents from djangojs.po, except for the translated msgstr and the content-type prefix. A formatting issue in the po file was probably preventing successful compilation.

thank you for your reply @regis, it was solved, I removed this contents and now it works.
But I have a new one, “Previous” and “Next” buttons. Tried to write them in django.po and djangojs.po separately and in both together but it is not translating.

Who knows how to solve it and please could you explain to me how it works what kind of content we should write in django.po or djangojs.po, for example, I have thought that this sentence shows after clicking “Sign up” and it is making by JavaScript, but it works only if I am writing in django.po . And what will happen if we write translations in both files at the same time?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.